Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

017-734 Error

Product Name: Phaser 6510
Operating System: macOS 10.15 Catalina

I have been trying to print a pdf file from having scanned it on a SnapScan scanner.  Just this pdf refused to print.  The same error shows up every time I try.  I have even tried to re-scan the document and print it.  There is no explanation except for the error code.  What is wrong here?  

0 Kudos
2 Replies
Joe Arseneau
Valued Advisor
Valued Advisor

Re: 017-734 Error

I suggest installing the printer via an HP Jet direct port. Or LPD, basically, just don't use IPP ever (Don't pick the printer from the list Apple gives you)

The error means this:

017-734 IPP Data Error RAP
017-734 Syntax error, usage of undefined command, parameter error, damage of the file, or
internal error of the decomposer has occurred during the decomposer process of a direct print
job that used IPP in its network protocol.
Perform the steps that follow:
1. Advise the customer to print by using a different print method (printer driver or utility other
than print from IPP) that is supported by the device.


But if it is really just the one job, easiest method is to select File > Print > Advanced and check the box for Print as image.

But that assumes you are using Acrobat/Reader and not Apples Preview, if you are using tat, I can't help and will differ to the no IPP thing

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
New Member
New Member

Re: 017-734 Error

The actual challenge is that not all PDFs are created equal.

So the real issue is not how you select your printer via the Apple Menu per se ... the issue is how the PDF was created in the first place. I've been running my Xerox C405 for more than a year without any problems. However, a set of emailed PDFs (probably created out of some open source PDF creator) would not print - spitting out the error 017-734. 

Fortunately, I ignored Joe's advice to redo the setup of my printer which is completely unnecessary but instead did take his advice to "Print as Image" which worked perfectly.

So while I was happy to add a Kudo to this thread ... it really should be a half-Kudo since the correct solution was in the second half of his answer. 


0 Kudos