cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution
Product Name: Phaser 7100
Operating System: macOS 10.15 Catalina

Since upgrading to 10.15.4 I have been unable to print from Apple apps, including Safari and Preview but also Readdle's PDFExpert. I get an error 016-572 or similar complaint about paper type or size, and no page printed. All of these worked fine before the upgrade.

Word and Adobe Acrobat do still print -- possibly because they do something non-standard with their printing? Safari, Preview and etc still print on the same printer from a Mac running 10.15.3. 

I have tried re-installing the drivers, and the printer, to no avail.

I'd be grateful for any thoughts or advice...

thanks and allbests,

 

0 Kudos
13 Replies
Highlighted
Valued Advisor
Valued Advisor

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

Word and Adobe Acrobat do still print -- possibly because they do something non-standard with their printing?

They actually follow the standards, which is why they still work. If Apple went and broke something in 10.15.4 then it could be a very long time getting it fixed because nobody is working and won't be for what may be some time due to Covid19.

I don't see anything about print specific issues, so you may want to other things people are reporting.

Like broken USB if you are usb connected and not LAN printing.

I'd suggest reporting it to Apple since it is just their applications.

My guess, from the fault code, is that it is sending the pages in millimeters or as A3/A4 instead of Letter Tabloid.

But since I am at home and not work, I have no Mac or printer to test that.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
Highlighted
New Member
New Member

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

I have the exact same issue. I upgraded the driver to 5.5.9 now and still the problem persists. Any help would be appreciated. 

0 Kudos
Highlighted
FreeFlow User

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

I believe that what you are experiencing is an issue that I have researched recently. I actually posted on this forum about this issue earlier this month. I was able to resolve this and I shared my findings with Xerox support today.

What I believe is going on is that the Auto Select option in the macOS system print window no longer defines the tray as auto select, instead it uses the default tray defined in the printer .ppd file. If you use an application that provides its own print dialog box, and you don't click to use the system dialog box, then your job prints fine because those applications send the tray call as "automatic". All Apple applications use the Apple print window so jobs from those programs will get sent to the default tray specified in the .ppd, which is tray 1 on every model that I have looked at. If the paper that you have in tray 1 doesn't match the paper size of your file than the job will get held for resources.

 

I resolved this by editing the .ppd file of the models that I tested (AltaLink C8045 and VersaLink C7030) by editing the following line in the printers .ppd file and reinstalling it using the custom .ppd.

Original PPD Text: *DefaultInputSlot: Tray1

New PPD Text: *DefaultInputSlot: automatic

 

I looked at the .ppd for your Phaser and the DefaultInputSlot setting is the same as the other models set for Tray 1.

Highlighted
New Member
New Member

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

Thank you very much, this worked for me and it has saved me a whole heap of time. 

You will never know how grateful I am! 

0 Kudos
Highlighted
FreeFlow User

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

You're very welcome Hamish. Thank you for confirming that this works for you as well since I only have one test system to work on and the more times that I can validate that something works the better.

0 Kudos
Highlighted
Member
Member

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

Thanks a lot. Your suggestion worked for me on a Xerox AltaLink C8045 and C8055.

But as soon as I change defaults options through CUPS web interface, i.e. one side printing, grayscale just to name the most common, the default output tray reverts back to Tray 1, although "automatic" is hard coded inside the edited PPD.

Alberto

0 Kudos
Highlighted
FreeFlow User

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

That is a downside to this simple interim solution. Since we are changing the default tray, but not adding a tray to the tray selection menu, setting and saving other defaults in CUPS will override the fix. I've looked in to adding the tray to the dropdown menu as an alternative. Otherwise you need to either edit the .ppd with all of your default settings included or do the following.

Install the printer.

Make your edits in CUPS to other defaults.

Edit the .ppd that the system generated on install to change the default tray as before.

Reinstall the printer using the custom .ppd. (this step might not be necessary)

 

Jesse

0 Kudos
Highlighted
New Member
New Member

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

Does anybody know if Xerox is on it to fix this?

0 Kudos
Highlighted
New Member
New Member

Re: Bug with Mac OS 10.15.4 and Phaser 7100 driver 5.5.2

Jump to solution

For what it's worth, i've filed feedback to apple. Let's hope Apple or Xerox is able to fix this asap.

0 Kudos