cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

CUPS and Xerox Global Print Driver spooler crash

I'm having an issue with Citrix Universal Printing and the Xerox Global Print driver.  Everytime I try to print to a printer (I've tried a WorkCentre 5638, WorkCentre 5230, and WorkCentre 5655) it crashes Explorer.exe and the print spooler.

 

I've tried the latest version of the PCL6 and PS GPD 5.303.16.  Also tried 5273.2302, and 5185.4200.

 

Here are the errors I get when I try to print:

 

Faulting application name: spoolsv.exe, version: 6.1.7601.17777, time stamp: 0x4f35fc1d

Faulting module name: UpClient64.dll, version: 6.2.101.29, time stamp: 0x4f45c60c

Exception code: 0xc0000005

Fault offset: 0x000000000015f562

Faulting process id: 0x9d0

Faulting application start time: 0x01ce83cc3a4bd160

Faulting application path: C:\Windows\System32\spoolsv.exe

Faulting module path: C:\Program Files (x86)\Citrix\Universal Print Client\UpClient64.dll

Report Id: 7029ef8d-efc6-11e2-9387-0017a477041c

 

Faulting application name: Explorer.EXE, version: 6.1.7601.17567, time stamp: 0x4d672ee4

Faulting module name: x2utilKN.dll, version: 5273.2302.0.0, time stamp: 0x508ff358

Exception code: 0xc0000005

Fault offset: 0x000000000009eedd

Faulting process id: 0x2d0c

Faulting application start time: 0x01ce83cda3a229f6

Faulting application path: C:\Windows\Explorer.EXE

Faulting module path: C:\Windows\system32\spool\DRIVERS\x64\3\x2utilKN.dll

Report Id: 70c5452d-efc6-11e2-9387-0017a477041c

 

The client is our Citrix image and the server is our printer server.  Both have the correct GPD and each time I changed versions I removed the driver package and installed a different version.

 

Any ideas on how I can get this to work?

0 Kudos
2 Replies
Highlighted
Community Manager
Community Manager

Re: CUPS and Xerox Global Print Driver spooler crash

Hi wjadams,

Thank you for using the Support Forum. Please take a look at the Global Print Driver Installation Guide and go to Installation and then Installation on Citrix Server.  If this does not help please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
Highlighted
Technical Escalation User
Technical Escalation User

Re: CUPS and Xerox Global Print Driver spooler crash

Hi wyadms2,

 

I am not sure about the citrix UPC error. I could assume you are printing via ICA session or something simliar. If this is true, then I would test printing directly to the printer or using print and point without using ICA channels for printing.

 

Apart from that tip. In order to attempt troubleshooting please try isolating the print spooler for the driver.

  1. Unistall driver and package
  2. Navigate to %SystemRoot%\System32\Spool\Drivers\x64\3 (or ...\x86\3) delete related left driver files
  3. Restart Print Spooler service.
  4. Install print driver and create the print queue. Use Add printer wizard, point to the print server and select the printer.

 

2nd part

Open Print Management console

Select the print driver

Right-Click and select "Set Driver Isolation" Select Shared.

 

If this does not work. You can also select "Isolate". This will isolate the print spooler servicefor that specific driver. Meaning that if the problem exist with the print driver should not corrupt spooler services that are dependent.

 

NOTE:

You can try this 2nd part first before the all system clean (unistall and reinstall printer)

 

Please select Accept as Solution if you feel this post has helped you.