cancel
Showing results for 
Search instead for 
Did you mean: 
mhwWC6515
New Member
New Member

Cannot print to Custom Paper size

Jump to solution
Product Name: WorkCentre 6515 DNI
Operating System: macOS 11 - Big Sur

Hello, I am having trouble printing to custom paper sizes ever since I upgraded the driver and firmware earlier today on my WorkCentre 6515 DNI. Printing to numerous standard sizes and types (paper, envelopes, labels) works just fine.

I have had this printer since 2017; it has been quick and reliable. I access it from a Macintosh. A few weeks ago I upgraded my Mac to Big Sur and have had no problem printing to both standard and custom sizes. Today, I upgraded the Macintosh driver for the printer, and I think it printed to custom sizes just fine (though the haze of time makes me question if this is really true). I then upgraded the firmware to the printer and I can no longer print to custom sizes (though all predefined sizes and media types works just fine).

Specifically, I was trying to print Christmas Card envelopes - which I had done successfully for the previous 2 days (before the driver/firmware upgrade) - with a size of 8.0 x 5.2 inches. First, I go into Page Setup from any program that still has a Page Setup command (not all programs do) and create my custom size and define the non-printiable area. And then I save the custom size. Next I go to the Print command and specify the parameters -  manual feed and media type (envelope), color, single-side, and select paper size (my custom size that is now on the list of choices). Next I go to the LCD display on the printer and change the Bypass Tray settings to my custom size and type.

Once I actually hit Print, I get an error on the printer display saying I need to check the Bypass Tray settings and say I need to set the settings to Letter, Plain, white. I press Start to continue. Then I get a dialog saying the printer is waiting for the required resources, namely the 8.5 x 11 letter size. My option is Resume and Delete. Resume just gets me in a repetitive cycle.

I have tried different custom sizes and different media types - all result in the printer telling me I need to put 8.5 x 11 letter in the Bypass Tray. I have also tried printing to the standard Tray 1; same results.

If I select a standard size (5x7, A4, #10 envelope), the printer correctly asks me to insert the appropriate media. Any ideas? Thanks.

0 Kudos
1 Reply
mhwWC6515
New Member
New Member

Problem Solved Re: Cannot print to Custom Paper size

Jump to solution

Problem Solved! I "deleted" my printer in Mac SysPrefs : Printers, then added it back. Not sure why this worked, but presumably I deleted some pref files when I deleted the printer. 

Previously, I had added the printer a 2nd time, but that didn't solve the problem.

I feel a bit foolish for not having tried this earlier. It would have saved me a few hours of troubleshooting.