cancel
Showing results for 
Search instead for 
Did you mean: 
Shaun Member
Member

ColorQube 8570 and older Mac OS - info

Though the literature mentions Leopard as the basic Mac OS for the 8570 I have found it works perfectly with OS 10.4.11 (Tiger) on my G5 PowerMac; everything installed just fine from the DVD.

I traded in my 8550, which was working with the G5 and with an older PowerMac 7300 (running OS 8.6). The Qube works fine with this older OS using the 8550 driver.

 

Just in case anyone's thinking of getting a Qube and wants to know this!

0 Kudos