Showing results for 
Search instead for 
Did you mean: 
AutoIT New Member
New Member

Disabling SOAP connection protocol stops Internet Explorer 11 from using the printer's web interface

Product Name: VersaLink® C405 Color Multifunction Printer
Operating System: Windows 7

My supervisor asked me to disable all of the unused protocols on the web pages of our brand new Xerox C405's, C605's MFP's and B400 printers.  When I did that and restarted the machine, the web interface was no longer usable by Internet Explorer 11 (on Windows/7 Pro x86 SP1 or Windows/Server 2008 R2).  I had to install Firefox in order to login as "admin" and complete the work.  This occurred over many printers.  I finally decided to remove the protocols ONE at a time and restart after each one.  When I finally got to SOAP (Simple Object Access Protocol, an extensible messaging system based on XML), I STOPPED and went back to one of the printers that could no longer use Internet Explorer 11 and RE-ENABLED SOAP with Firefox and restarted the printer/MFP.  When the printer came back online, I tried Internet Explorer 11 (32-bit) and it worked as expected!  I then used Firefox to go to each of the other printers and enabled SOAP and restarted each device.  Now Internet Explorer 11 works on all the MFP/Printer's web pages.  With SOAP disabled, both Firefox and Chrome MUST login as "admin" to access the web pages.  Otherwise, a black overlay with Requested Operation cannot be completed is presented.  My suspicion is that this was never TESTED as all of our C405/C605/B400's have this issue!  I wanted to try Microsoft Edge but our Windows 10 Pro systems do NOT have access to the Printer Network (VLAN).  One can say that IE 11 is on the way out but the Firefox and Google Chrome behaviour with SOAP disabled is NOT acceptable either, as the general user web page is not available with SOAP disabled, even with Firefox and Chrome. While I am an Electrical Engineer by education, my background before I retired from IBM was Software Test.  I would have flagged this issue as a Severity ONE Defect - guest user web site pages not availble after SOAP is disabled. admin login required.

Thanks for your time and efforts!  Note Well that all Windows updates (applicable) have been applied.

0 Kudos
1 Reply
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Disabling SOAP connection protocol stops Internet Explorer 11 from using the printer's web inter

 SOAP is commonly used in HTML5, and clearly is on FujiXerox machines, if you are looking to disable unused ports, you just found one that clearly isn't unused.

If you have a security concern about it, document it and show a wireshark trace showing the protocol doing something it shouldn't, submit to Xerox in a spar with second level, or direct via

As for IE11, it behaves the same as Firefox/Chrome and EDGE on my PC, login as admin is still needed or you get errors, mostly because without SOAP the printer can't verify you are able to view the page you are on do to overlays and crosslinking weblets.


Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

0 Kudos