cancel
Showing results for 
Search instead for 
Did you mean: 
dvump25 New Member
New Member

Duplex Printing No Longer Available

Product Name: Xerox WorkCenter 6515
Operating System: Windows 10 x64

A few days ago I get a message telling me the machine needs to update the software, so I went ahead and let it update. Well, after that completed, everything went to hell in a handbasket! First, the printer was no longer recognized. It used to show as "WorkCenter 6515," but that wouldn't work. When I went to reinstall it, it showed as "Xerox WorkCenter 6515," so I chose that. However, that printer does NOT offer duplex capabilities! Immediately before this stupid update, I was able to duplex print quite easily. Now I can't even find the option to do it. It's not possible whether I choose the options in MS Word, a .pdf file, or whether I try to go through the printer's options on its menu.

Just what the hell IS it with this printer? When I owned the Dell 3110, that thing worked flawlessly. Scanning documents into a pdf file worked with ease (can't do that with the Xerox unit, though). Double-sided (duplex) printing was easily accessible and worked all the time (no longer available on the Xerox unit, though). This is clearly the worst piece of crap, expensive printer I have ever purchased! I despise it!

Why Dell ditched their own awesome full service printer for this piece of junk I'll never understand! 

0 Kudos
1 Reply
Community Manager CherylO-Xerox
Community Manager

Re: Duplex Printing No Longer Available

Hi dvump25,

Thank you for using the Support Forum. Please take a look at the solution for Duplex Greyed out.  If this solution does not help please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos