Showing results for 
Search instead for 
Did you mean: 
1 Reply
Community Manager
Community Manager

Re: Firmware update check has never worked

Hello DavidM-MSI,

It sounds like you have two problems so here are some articles that may help you:

How To Enable or Disable the Remote Services Option

Remote Services Error Message

Remote Services Configuration Considerations

How To Update the Printer's Software (Firmware)


Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Firmware update check has never worked

Product Name: VersaLink C7020/C7025/C7030 Multifunction Printer
Operating System: Windows 10

Our pair of 7020 printers are connected by copper Ethernet to a LAN and are pingable and have the correct DNS settings (IP V4) but despite being set to 'auto check weekly' have never connecetd to Xerox. If I try by hand I too fail to connect and get a 'connection failed, try later' msg.

Can anyone suggest what is going on and how best to update the firmware?



0 Kudos