cancel
Showing results for 
Search instead for 
Did you mean: 
DrStrange
New Member
New Member

Firmware upgrade failure on WorkCentre 6515DN

Product Name: WorkCentre 6515
Operating System: Windows 10 x64

I am unable to upgrade the firmware on a WorkCentre 6151DN from 65.66.91 to 65.69.51. Using the Windows Firmware Upgrade Utility, with an ethernet cable connected between the printer and router, the firmware appears to transfer fully, but does not let me click on the next button. After 10 minutes or so the utility states "fail to check updating. Please check the device" then  "unknown to update". With a USB cable connected between printer and PC, the firmware does not appear to even transfer. I have changed the setting in the printer to make Ethernet the primary conncection and disabled wi-fi, then tried again but that didn't work.

I am unable to use the EWS method to upgrade because in the "Admin>System>Software Update" page I have never had the setting which allows you to select the .bin file. On this page there is only the setting to enable/disable software updates.

While this is happening, the printer is displaying the expected message "An authorized user is making changes to this device, please wait...." When I power off and turn the printer back on, it prints out a software upgrade report "The software upgrade failed(017-759) (Upgrade NG)" then prints out the versions of the various ROMs in 65.66.91

The firmware was upgraded successfully in May 2021 to 65.66.91.

Ethernet:

Capture1.JPG

Capture2.JPG

Capture3.JPG

 

USB:

Capture4.JPG

Capture.JPG

17 Replies

Re: Firmware upgrade failure on WorkCentre 6515DN

Exact same issue here.  Won't update in in TCIP/USB Cable, or even USB Flash Bootloader mode either, essentially this firmware is faulty for the 6515.  Have tried 5x so far, using the above methods and also re-downloaded and extracted the file.

 

It feels like the firmware is corrupted or faulty on the Xerox and needs to be removed. before more people waste their time trying to update. 

SadAdmin
New Member
New Member

Re: Firmware upgrade failure on WorkCentre 6515DN

Confirm the same results with 8hrs effort to update using VersaLink firmware Install Utility v5.3.6.19. The only firmware I could find was from the WorkCentre 6515 Service Pack (PL7-R9) this is an encrypted *.BIN file and requires v65.59.11 or higher. Questioned update utility so selected a downgrade firmware that was unencryped which is the Bridge version Xerox recommends v65.59.11 and that installed fine so the utility works. Immediately after down grade after waiting for printer to finish processing the firmware update and printing its Upgrade Report and Startup Page I tried installation of the service pack Bin file (656951_WC6515_E.bin).

Note a series of Xerox links directed me to from the urgent Firmware Update for the WorkCentre 6515 to the service pack as the latest version.

Any help would be grateful, seems the encrypted firmware is the problem, noticed there are options to specify passwords for the files perhaps whom ever compiled the encrypted *.bin file used a different PW than what is in our printers.

Thanks for reading my problem,

SadAdmin

Link.png

Notice.png

Pack.png

Re: Firmware upgrade failure on WorkCentre 6515DN

I'm facing with the same issue, I followed all the steps documented and succesfull updated the firmware 655911_WC6515 but the installation of the version 656951_WC6515_E using FWDLMgr prompt an error after 5-10 min. It seems the upload works fine but the device can't apply teh update.

thx

Simone

Re: Firmware upgrade failure on WorkCentre 6515DN

Totally agree with you!!!

dleduc
New Member
New Member

Re: Firmware upgrade failure on WorkCentre 6515DN

I hate to just say me too, but I wanted to make sure that I'm in the group that might see a solution to this.  

I too saw the notice that there was an importnat firmware update.  It took me awhile to figure out how to do firmware updates, but finally I was able to use the firmware update utility to upgrade to the bridge version of 65.59.11 jsut fine.  Then when I tried to to the upgrade to 65.69.51 using the network method the firmware utilty appeared to work.  The progress bar made it to the far right and then nothing happened.  The finish button never became active.  I then tried the same utility with the USB connection.  At least this showed the 100% number on the completion level, but still the finish button did not become active and the printer display kept showing that the printer was being updated.  After a long time I restarted the printer and it printed a shee saying that the update failed.  Is there a solution to this firmware uprade dilemna?

WH57
New Member
New Member

Re: Firmware upgrade failure on WorkCentre 6515DN

I have EXACTLY the same issue/experience. It is a bit disconcerting that this was reported more than a month ago and there appears to be no advice or action from Xerox. Is there a way to approach them directly, to request a solution?

GuyAdams
New Member
New Member

Re: Firmware upgrade failure on WorkCentre 6515DN

We too have experienced the same issue as others. We have 18 WorkCentre 6515, not a single one have we managed to upgrade to 65.69.51 - (PL7-R9).

I use the version 5.3.6.19 of the firmware upgrade utility on Windows. Thus far I have tried:

1) Running the utility as administrator

2) Uninstalling antivirus and disabling firewall

3) Windows 10 and Windows 11 x64 workstations

4) Factory defaulting a printer and attempting the upgrade

Many thanks, 

Guy

TammyL-Xerox
Community Manager
Community Manager

Re: Firmware upgrade failure on WorkCentre 6515DN

Hello, 

We have reported the issue with the firmware failing, they are in the process of reloading the firmware on xerox.com.  Once this is completed we will update this post. 

Thanks,
TammyL-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!
CathyO-Xerox
Community Manager
Community Manager

Re: Firmware upgrade failure on WorkCentre 6515DN

Hello,

We have been informed that they have fixed the firmware. If some of you can try it and and let us know if it works, that would be great:

https://www.support.xerox.com/en-us/product/workcentre-6515/content/156307?language=en&platform=win1...

Thanks,
CathyO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!