cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

FujiXerox C7600 : Weird print issue with light color

Jump to solution
Machine Model : FujiXerox DocuCentre-III C7600
 

HI everyone, i'm having issue with light color print. From the photo, the light blue is covered by a smear of magenta, but the smear is not on the white area. It only happened to the light blue area. 

I've cleaned the ROS, also swapped yellow drum and cyan drum (because i currently dont have new drum) the magenta look lighter but still persist. Could it be drum or other reason?

smear of magenta (photo)111.jpgOnly happened to light blue area, White area is not coveredOnly happened to light blue area, White area is not covered

0 Kudos
5 Replies
Highlighted

Re: FujiXerox C7600 : Weird print issue with light color

Jump to solution

Some update, while trying to figure out what's wrong with the machine. i found that at the developer unit, there's some toner sticking on this metal rod. It matched with the print out smear. I've cleaned it, but eventually it will come stick back. How should i prevent the toner to stick on the metal rod?p1.jpg

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: FujiXerox C7600 : Weird print issue with light color

Jump to solution

Hi,

From what I see there is a problem with the magenta developer housing that can damage the drum.

 

Gabi

0 Kudos
Highlighted

Re: FujiXerox C7600 : Weird print issue with light color

Jump to solution

HI Gabi,

Thanks for the replied. Is there a way i can fix it?

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: FujiXerox C7600 : Weird print issue with light color

Jump to solution

First clean well that leaking of the developer housing (where is developer material and not toner what you see in that area under the developer housing) and then swap the magenta drum with another (C or Y). Check if developer material still leak and if it so replace the developer housing.

Highlighted

Re: FujiXerox C7600 : Weird print issue with light color

Jump to solution

Solved !! i cleaned the developer housing and also replaced new developer material. The smear is gone! Thanks so much Gabi !!

0 Kudos