cancel
Showing results for 
Search instead for 
Did you mean: 
1 Reply
TammyL-Xerox
Community Manager
Community Manager

Re: I can't install the Phaser 6510 firewall 64.74.51

Hello xeroxForLife, 

Sounds like you have tried everything already, so I suggest calling into your local support center. 

Worldwide Contact Page:   

http://xerox.bz/worldw 

Thanks,
TammyL-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

I can't install the Phaser 6510 firewall 64.74.51

Product Name: Phaser 6510
Operating System: Windows 10 x64

I have a Phaser 6510 with firmware 64.73.72 and I would like to update to the 64.74.51 firewall because every now and then the printer crashes.
At this moment the printer works perfectly.
I use the printer with USB cable because the Wi-Fi module has never worked.
I use FWDLMgr.exe because I don't know the IP to access the printer.
I get this error message but there are no pending prints. I have already restarted my PC and printer.

Immagine.png
I don't understand why Windows shows me 2 or 3 printers. I only have one Xerox.

Immagine2.png

Immagine3.png

I am using this procedure:

Phaser 6510 - Firmware 64.73.72
https://download.support.xerox.com/pub/drivers/6510/SPs/win10/ar/PH6510_PL7-R13.pdf
https://www.support.xerox.com/en-us/product/phaser-6510/content/161415?language=en&platform=win10x64

Versalink Firmware Installation v8_Pagina_4.jpg
Thank you

Tags (1)
0 Kudos