cancel
Showing results for 
Search instead for 
Did you mean: 
nycnewman New Member
New Member

Issue when using IPP to connect from macOS 10.14.4 (Mojave)

Operating System: Other – specify OS in post

Wondering if anyone else seeing issues with using IPP to connect to Xerox Altalink c8030 printer. We are seeing errors from the CUPS print manager where it fails to properly process the print job during the Validate-Job phase of an IPP print run. The ipp process fails with error and printer permanently stays in Pause mode. No jobs are ever processed. 

Not clear if this is a Xerox driiver issue, CUPS issue or something else. Not specifically printer issue as client drops the connection to the printer during the procesing of the Validate-Job so not a printer side issue.

Issue seen a number of macOS Darwin 10.14.4 machines with Xerox c8030 latest firmware / driver.

LPD appears to work but becomes very slow after 24 hours.

0 Kudos
6 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

LPD should not change after 24 hours.

Since you have the latest firmware, enable network trace on the printer ala EWS > Properties > Security > Logs > Network troubleshooting.

Then send a print via IPP, after a while, stop the trace and download it to the Mac, install Wireshark and filter it for IPP.

No idea what you will find, WSD and IPP ports have proven very unreliable over the last few years so most won't use them at all. I have had quite a lot of customers who found disabling IPv6 on the printer helps, but the initital handhake <Conecting to printer> still takes forever

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
0 Kudos
nycnewman New Member
New Member

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

I discussed with the developer of CUPS (who is also at Apple) via Github. Apparently the Xerox printer is closing the connect right after the Get-Attributes call and not honouring the HTTP Keep-Alive. IPP (apparently) requires the connection be left open.

So the issue is that Mojave IPP backend expects to send to the existing open connection but the printer has closed already. Thus printer pcap show FIN response from printer and client pcap shows client attempting to send to printer the Validate-Job phase. Seems like Xerox need to fix their firmware for this issue.

Airprint was suggested but this seems to be IPP under the hood for this Xerox machine and is no better. Been recommended socket conection but would be good to get IPP fixed.

Client -> Printer - IPP Request (Get-Printer-Attributes)

Printer -> Client - HTTP/1.1 100 Continue

Printer -> Client - IPP Response (successful-ok-ignored-or-substituted-attributes)

(with immediate FIN on TCP level)

Client -> Printer - IPP Request (Validate-Job)

but then client drops TCP connection

 

Highlighted
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

Since he has documented proof of it being Xerox's fault, get the logs he has showing it, the Config sheet of the Xerox device and submit it to Xerox Engineering (Call on your printer, get to 2nd level, supply config and all associated file proof and they will replicate and submit for a spar to be developed.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
0 Kudos
jdn New Member
New Member

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

I am seeing the same behavior on Mac OS 10.12 and 10.14 when printing to a Xerox C70 (Integrated Color Server). It happens to us on larger jobs that take a while to spool to the printer. Job sits in queue for a while and then the queue pauses. 

After reading your findings here (thank you!), I tried increasing the timeout setting for the IPP protocol. Changing it from 60 seconds to 600 seconds seems to have fixed the issue we've been having. My guess is if a job took over 60 seconds to spool, it timed out and caused the error on the client. 

Looking for suggestions for any way I can help get this on Xerox's radar as it would appear to be a wide-spread bug in the way the IPP protocal is implemented. Or at least how it reacts with MacOS clients in the real world. 

0 Kudos
nycnewman New Member
New Member

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

How did you change timeout? Using contimeout parameter? Seems default for that is a week.

I haven;t found a contact at Xerox to report issue but working on finding this. Also note that there is a separate bug that causes issues for Xerox (C8030 definitely) with large filenames. Needs a latest firmware to fix.

0 Kudos
nycnewman New Member
New Member

Re: Issue when using IPP to connect from macOS 10.14.4 (Mojave)

Xerox are claiming that this fixes IPP issues for C8030 (not expliictly referenced in release notes though...).

https://www.support.xerox.com/support/altalink-c8000-series/file-download/engb.html?&contentId=14372...

0 Kudos