cancel
Showing results for 
Search instead for 
Did you mean: 
youritguysc New Member
New Member

Issues printing to Workcentre 7556 from Mac OS Catalina

Product Name: Workcentre 7556
Operating System: macOS 10.15 Catalina

Hello - since upgrading to Catalina on several Macs I’ve had problems printing to a Workcentre 7556. Some apps will print to it, such as TextEdit and Notes, but most others will not (Word, Safari, PDF Expert, etc.). When a print job is sent from those apps, the printer will make the noise as if it’s about to print and then…nothing happens. No error messages are generated either on the printer or the Mac. 

A few things I tried to fix (on several Macs):

Installed the latest driver, 5.4.2

Tried different user codes for each print job

Reset the Mac OS printing system and reinstalled the printer

One thing I noticed while reinstalling the printer was that the printer discovery box (where previously I could find the printer on the network and install from there) flashes for just a moment and then jumps right to a screen that prompts me to set up the printer directly within the Mac OS Printers System Preference pane, so that’s new. 

After none of these fixes worked I reached out to Xerox phone support, and after describing the issue was escalated to level 2 support. I spoke to someone who kindly listened to my issue and the steps I had taken to diagnose but then informed me that he was a “PC guy” so he had to check with the “Mac guy”. When he came back on he told me that it was a known issue and they were waiting on “Mac” to fix it. Obviously he meant waiting on Apple to fix it, however he couldn’t provide any other information, such as whether a radar been filed for this bug in Catalina assuming that’s the root issue. 

Anyway, I’ve seen several posts about Catalina here so there’s obviously problems but I didn’t see this specific issue and was hoping someone could provide a workaround. Thanks in advance!

0 Kudos
1 Reply
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Issues printing to Workcentre 7556 from Mac OS Catalina

If this is your only printer, go to Apple > System preferences > Print and scan and rightclick where the printers are on the left, and choose Reset print system

If it isn't your only printer and you can't stand to reinstall the others too, just select the 7556 and choose the minus sign to remove it.

Then, Select the plus sign to add a printer and choose the IP tab and fill it in manually. Use the printers IP address (press the Machine Status button and it will be center of the screen on the 7556)

Protocol should be either LPD or HP Jet direct (One may work better than the other)

Name is what you want to call it, and the Use needs to be exactly as shown (Right now yes, obviously in the future the numbers will increase)

1.PNG

Now, open an app to test, get into the print window, make sure the Preset is on Last used Settings

Change the next dropdown to Xerox Features (If it says Printer Features see below)

Change the next to Advanced then go into Accounting and set your settings as needed

2.PNG

See how that works, it should simply work.

 

 

 

***If it says Printer Features and not Xerox Features your system is corrupted in the spooler, that was caused by Apple via Library Validation, it was finally fixed in 10.15/Catalina, there are as you no doubt saw, a ton of those posts. It took them years to fix it, but they did, so if it isn't working on yours, either a print system reset will be needed (as stated above) or a repair install of MacOS

  • Restart your Mac and then hold down ⌘ + R to activate Recovery Mode
  • In the first window, select Reinstall macOS ➙ Continue

Then of course you would need to install the printer again, don't use the installer to completely install it though, just exit out when it asks you to select the printer and go do it manually.

And if you are wondering about the Last used settings, that was a trick to getting the accounting to work in the sandbox apps that had the library validation problem and would only show Printer Settings, you just used a non sandbox apple app like Firefox, Acrobat etc that did have Xerox features and sent the job properly, then used the broken apps and had them pull the settings in the background via the Last used Settings

 

 

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe