cancel
Showing results for 
Search instead for 
Did you mean: 
AndyTr New Member
New Member

Jobs getting stuck in spooler

Product Name: VersaLink® C405 Color Multifunction Printer
Operating System: Windows 10 x64

Hi,

We've got 2 x Xerox C405 shared on a network between 3 x Windows 10 x64 computers, connected via a Netgear Pro managed switch (default config).  The printers are on the latest firmware.  The computers are different manufacturers, built using a clean Windows 10 Pro ISO, as downloaded from the Microsoft site, with all updates installed to date.  Windows 10 firewall is enabled on all machines using default config.  There is no third party AV or firewall app installed.

The printers were installed about 12 months ago, but have continuously suffered from jobs getting stuck in the Windows print queue.  This happens to each computer sporadically about twice per week.  There doesn't seem to be any pattern we can spot.  No messages on the printer display/admin page, affects all apps where a printer is required, occurs on different computers at different times, etc.

We've tried different versions of the drivers.  One computer is on PS, while the other two are PCL6.  We've used the drivers supplied by Windows Update and a couple of different versions of the Xerox website drivers.  All have the same issue.

One of the computers has been connected via USB, rather than network, for several months, but still gets the same problem.

Stopping/starting the Windows spooler sometimes works, sometimes doesn't.  Stopping the spooler and deleting the files manually sometimes works, sometimes doesn't.  Restarting Windows works most of the time, while occasionally the printer also needs powering off at the wall and restarting in order to clear a message displayed in Windows, such as "Door open" when the door isn't open, etc.

To me, it seems the printer and the Windows driver are having trouble communicating a specific message, but I'm unsure how to troubleshoot this further.

Does anybody have any suggestions please?  The 4 users of these 2 printers are getting extremely frustrated and suggesting they replace them with something else, which seems ridiculous, given they're probably less than 12 months old.  We have a Xerox 6605 on a different switch that has worked flawlessly for 3 years, so the obvious thing to blame would be the C405, but I can't rule out a network issue, but can't explain why it works most of the time and happens so sporadically yet frequently.

0 Kudos
2 Replies
Technical Escalation User DavidX28897-xrx
Technical Escalation User

Re: Jobs getting stuck in spooler

I would use a Cat5 tester and check for an intermentant short/open on one or more of the network cables. 

Other things that come to mind:

1. check for duplicate ips. 

2. Ensure the printers are not managed by windows and are printing direct to ip instead of a WSD port under printer properties->ports. Also double check the driver in use is indeed a Xerox driver under printer properties->advanced. 

I've seen plenty of computers with a "X model name PS" name for the printer but when I check the actual driver in use it's a different model's driver. This is due to clicking "Yes" when Windows asks to install the recomended driver. 

0 Kudos
alan.frth Occasional Contributor
Occasional Contributor

Re: Jobs getting stuck in spooler

Hi Andy,

Have you tried:

  • turning off the Windows firewall on one or more machines
  • turning off one of the printers

 

0 Kudos