Showing results for 
Search instead for 
Did you mean: 
2 Replies
Technical Escalation User
Technical Escalation User

Re: Local printer setting does not transfer over to rds session (Windows server 2012 - Windows 10 1

From what I can gather Easy Print doesn't support custom driver settings.

Valued Advisor
Valued Advisor

Re: Local printer setting does not transfer over to rds session (Windows server 2012 - Windows 10 1

Hello Nagy Krisztian.

If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: Phaser 3320.

Alternatively, you can visit our Contact Us page for other support options.

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos

Local printer setting does not transfer over to rds session (Windows server 2012 - Windows 10 1809)

Product Name: Phaser 3320
Operating System: Windows 10 x64

Dear forum contributors!

I have a complicated problem with Xerox 3320 and 3330 printers, so please bare with me. 

The state of the problem is as below. I am out of ideas, I tried everything I can possibly think of. 
Would appreciate your help. 

We use Windows Server 2012 as a RDS Server. Our users work using our RDS Server. They each have an RDP session and they use our own medical software developed by us. 

This approach (RDS) seems logical because every user has a folder for their documents, and the local computer which they use to connect to the server is not involved. 
Provided that the local computer has internet access and a local printer attached to it every feature we want works OK. 

Up until this point we used Xerox Phaser 3330 printers with Xerox 3330 PCL6 machine specific driver to print our documents. Most of our workstations run Windows 10 Pro 64bit. 

Every client PC is joined into our AD (Server 2012) and we used Microsoft Easy Print Services to work around the hassle of installing each and every necessary print driver on our Terminal Server. 

In a normal workday we use 2 paper formats. (A/4 and A/5)
The Microsoft Easy Print solution wasn't the perfect one for us because every time we needed an A/5 print we had to pull out tray 1 (Default paper size: A/4). Provided that we did so the printer pulled in paper (A/5) from the bypass tray. 

Not too long ago we had an idea. There is a GPO concerning Easy Print settings. If you have the same driver installed onto your Terminal Server and the local client you can use the driver in the RDS redirected scenario and gain access to more features even when printing on RDP. 

I installed Xerox GPD 5.64 on all of our clients connected to 3330 and 3320 machines as well. 
I changed the Bypass Tray Paper Size setting in Xerox CentreWare on all printers. 
(they have an IP and the are added to windows using the TCP/IP Port setting )

At this point I had success printing A/4 and A/5 documents. But I also wanted to set duplex printing to be the default action. 
As far as I know the local printer setting matter the most, because RDP sessions get the printer setting from the local computer. 

I set duplex correctly in printer setting and on the special tab in defaults as well. 
But no matter how I set it during an RDP session the printer refuses to print duplex pages. 
I can always change the settings before each print in setting in the RDP window, but that is time consuming and tiring at best. 

So my local printer setting does not transfer over to my RDP session resulting in simplex prints all the time. 

PS: I tried using Xerox GPD 3.7, and machine specific drivers. From the Windows Print Management Console I checked that the printers are recognized with the correct driver. 

Please help, I am lost. 

Yours faithfully 

0 Kudos