cancel
Showing results for 
Search instead for 
Did you mean: 
brave305 New Member
New Member

Need an older printer driver

Hello everyone, 

 

I need the Xerox GPD PCL 6 in Version 5520.600.0.0 for Windows 10 and 7 x64. 

 

We are needing this because the new drivers seem incompatible with the ones in our Citrix Servers. 

The Auto-Created Printer doesn't recognize the attached finisher and doesn't give us the option in Citrix to staple. 

 

thanks!

 

0 Kudos
1 Reply