cancel
Showing results for 
Search instead for 
Did you mean: 
2 Replies
KK-NJ
Frequent Member
Frequent Member

Re: Phaser 7500DN driver issues

I would double check to see the connection type for the print queue in CUPS (http://localhost:631).  When this used to be widespread with Sierra (or High Sierra...can't remember), we'd have to make sure the driver was configured using the JetDirect/Socket port pointing to the printer's IP address.  This has proved reliable and has also fixed overall print response times vs. letting the printer be picked up over Airprint/IPP, etc.  LPR is also a reliable connection method.

Also make sure you're using the latest Mac driver for the correct version of MacOS from the drivers & downloads page.  Autodetection of the OS has been faulty lately on the support site so you'll have to manually select the correct one and filter.

TammyL-Xerox
Community Manager
Community Manager

Re: Phaser 7500DN driver issues

Hello nunnethan, 

  • I see no one has responded to this post yet. So, at this point I would recommend contacting your local Xerox Support Department to speak with a Product Specialist for more assistance. Please call 11-800-835-6100. 

 

Thanks,
TammyL-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!
0 Kudos
nunnethan
New Member
New Member

Phaser 7500DN driver issues

Operating System: Not Specified

Hi there,

I'm running macOS 14 on one computer and macOS 12 on another. Both have the same issue. I have a Phaser 7500DN.

I'm having problems with what I assume to be a recent driver update for the Phaser 7500DN. Although it doesn't affect the functionality, it appears as though Xerox Features has been replaced with Printer Features in the print dialog across all apps; to help explain, below are some screenshots of expected behaviour versus actual behaviour.

actual behaviour (note "Printer Features")actual behaviour (note "Printer Features")actual behaviour of "Printer Features"actual behaviour of "Printer Features"expected behaviour (as with the driver for Versalink C8000)expected behaviour (as with the driver for Versalink C8000)expected behaviour of the prompt (this is how it appeared around two weeks ago)expected behaviour of the prompt (this is how it appeared around two weeks ago)These 'new' "Printer Features" feel like the new driver has half-installed, and I believe the problem may be down to Xerox. However, I wanted to check that it's not something only I'm experiencing.

I have, of course, tried uninstalling the printer and driver and reinstalling. I cannot access a previous version of the driver to verify that this new driver is causing the issues because it does not appear Xerox offers this.

Any assistance is gratefully received; preferably someone telling me that I'm not going insane and that this is a widespread issue would be wonderful. The 'new' screen presents all the same options as before, but in a weird way and not like the screen I believe should be in its place.

Thank in advance!

– nunnethan

0 Kudos