cancel
Showing results for 
Search instead for 
Did you mean: 
1 Reply
TammyL-Xerox
Community Manager
Community Manager

Re: Postscript error when printing certain fonts from Mac (but not Windows)

Hello Steve_BMH_Klein, 

Sounds like you have tried everything already, so it would be a software escalation: 1-800-821-2797.

Thanks,
TammyL-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Postscript error when printing certain fonts from Mac (but not Windows)

Product Name: AltaLink C8130 / C8135 / C8145 / C8155 / C8170 Color Multifunction Printer
Operating System: macOS 12 - Monterey

Note: Our Macs are running macOS 14 - Sonoma, but the "operating system" pulldown apparently hasn't been updated in over two years, so I chose the closest match.

We have a few standard Adobe fonts used for all corporate communications. Documents with those fonts don't print from Mac users, and I've been tasked with finding a solution. We have literally dozens of affected Macs.

The problem afffects all of the built-in apps and Microsoft apps (Word, Excel, etc.).  If any document contains this specific font, this is what shows up on the printed page:

ERROR invalidfont
OFFENDING COMMAND: definefont

STACK:

/Font
-dictionary
/QNDGYI+Factoria-Book

Note: the letters on the bottom line are different, depending on which font was used. If the document contained Factoria-Bold, the letters were YBPIJD.

Here's the troubleshooting steps I've taken so far:

Since I work in IT, I have access to spare machines.  I wiped a Mac and Windows PC, installed the OS from scratch on both, then installed Microsoft Office on both of them.

Then I downloaded and installed the most recent version of the driver for that printer on both computers.

Then I installed the fonts on the Mac, and created a test document in Microsoft Word where each line had a different problematic font.

(Just to be extra careful I used the "Validate' function in the Mac's Font Book utility to verify that the fonts were damaged or corrupt.)

I tried to print that document, but (as expected) I just got a page with the above error.

Then I copied the document and fonts from the Mac to the Windows PC, installed the fonts, and tried printing the same document to the same printer.  It printed perfectly.

Both computers used:

  • The same Microsoft Word document,
  • The same Adobe fonts, 
  • Rhe same app, Microsoft Word, and
  • The same printer.

Since it worked on Windows, we can rule those out as possisble causes for the problem.

What differed was only the operating system and the printer driver.

So I installed the driver for an HP printer on the Mac, and the document printed without issue.

So now we can eliminate macOS as being part of the problem.

All that's left is the driver.

In this forum I found a post from someone else who had a similiar problem on Windows, (Here's a link to the post.)

That user was told to enable a driver feature called "Download as Softfont," but that option doesn't exist in the Mac drivers.

If you like, I'd be glad to provide a copy of the document and fonts so you can reproducte the problem and hopefully find a fix.

What's Since only the driver is different, all evidence points to the driver.

Since the document file, app, fonts, and printer are all the same, I suspect a bug in your Mac driver.

 

0 Kudos