cancel
Showing results for 
Search instead for 
Did you mean: 
CDonofrio
New Member
New Member

@PrintByXerox - Registered URL Invalid Error

Operating System: Windows 10

Hi, 

We're experiencing an issue where a number of our AltaLink C8070 printers are generating an error message whenever a user attempts to access the @PrintByXerox app from the device. 

The error message displayed:

Registered URL (https://xmpceip.services.xerox.com...xxxxxx) is not valid. Please contact your Xerox Workplace Cloud administrator.

2nd level has worked with me to try the following procedures during our troubleshooting calls:

1) Apply a new clone from a verified working printer (did not resolve)

2) Remove then re-discover/re-add printer to XWC (did not resolve)

3) Repair the printer in XWC

4) Full hard disk overwrite (did not resolve)

5) Disable/re-enable proxy settings on the device (did not resolve)

I've tested the Service URL through the device web UI and everything is confirmed as successful. 

Something that I've noticed, however, is that when removing/re-adding the printer to XWC, the Client App installation feature takes quite a while to fully load. The gear will appear in the icon, but won't fully show as enabled until several hours later...sometimes not even until the following day. This only happens with these particular printers. Not sure if it's related, but worth mentioning as this behavior is unique.

It should be noted that direct print capabilities through the client app still operate as expected, but this is not a secure print method and is not used by the business. 

At this point, no users can print to these devices as our organization strictly adheres to Secure Print functionalities. The @PrintByXerox app is the only way for users to retreive their print jobs from the cloud securely. Additionally, this prevents our users from also using Guest Printing methods as an interim solution as this error also appears when they try to access the screen to enter the Express Code.

Does anyone have any thoughts or suggestions as to what might be causing this? 

0 Kudos
2 Replies
TonyP-Xerox
Analyst Nation Moderator
Analyst Nation Moderator

Re: @PrintByXerox - Registered URL Invalid Error

Hi @CDonofrio, I've seen issues where the @PrintByXerox App on the device needs to be updated and it won't work until it is at the latest version. 

To get @PrintByXerox to work for me, I uninstalled the app from the device web UI, and then reinstaled it from the App Gallery.

Tony

CDonofrio
New Member
New Member

Re: @PrintByXerox - Registered URL Invalid Error

That's the tricky part...

For some reason, @PrintByXerox isn't shown in the Weblets section of the web UI.

The App Gallery weblet is there, but nothing else. 

If I enable the App Gallery on the device, I can see that @PrintByXerox is installed (v 1.1.12), but no option to remove from there. It just says that it's "Installed". Strangely enough, in the App Gallery weblet, if I click on Installed to see what's on the device, @PBX isn't even listed, but it's definitely on the device.

I also tried re-installing the @PBX weblet (downloaded from the online App Gallery; same version) directly from the web UI, but I get a failure message. Perhaps because the app is already installed on the device?

Really trying to avoid a full factory reset if at all possible. 

 

EDIT: Another relevant note - The app does almost open on the device. It'll show the page with the Express Code button as well as the authenication QR code, but at that point, it reverts to the error message almost instantly every time.

0 Kudos