cancel
Showing results for 
Search instead for 
Did you mean: 
indubhushan New Member
New Member

Printer WorkCentre 5020 not working/can't (re)install (Win7/10). No USB-printer port available

Product Name: WorkCentre 5020
Operating System: Windows 7 x64

I'm writing this, because I've tried everything to reinstall not working printer Xerox WorkCentre 5020. Previously, it worked on Windows 10, but stopped working. I was trying to reinstall it, but no success. 

 

Then I've tried to reinstall it on older Windows - Win7, but again - no success. Specifically, I'm trying to install drivers from page http://www.support.xerox.com/support/workcentre-5020/downloads/ruru.html?operatingSystem=win7x64&fil...

but no driver can be installed anymore. I'm trying running setup from unpacked archieves. Start screen appears with "Install all drivers (scan and printer)" button, program starts "installing". It askes to accept license agreement, then to connect USB printer. I press OK, then nothing happens. it doesn't appear in "devices list" (press Win+Break and choose device manager).

Also, manual installing from .inf file doesn't work. I go to PrnDrv\Russian\WinXP_x64\,

select xrhnlzir.inf, and click "install' in context menu. it says "this INF file doesn't support this methid of installation". Or, I go to control panel, click "add new device/printer", select manually the same .inf file. Then it asks to select a port, but there is no "usb port" available. I choose "create new port", name it "USB001", but still printer doesn't print anything. the thing, USB port is not available in Printer's ports list. My manual adding it from usbprint.inf or usbport.inf c:\Windows\inf\ doesn't work. I mean, in ports list of my printer, I click "Add port" -> "Local port" -> "new type of ports" -> choose this inf (usbprint.inf or usbport.inf from c:\Windows\inf\), but it doesn't go anywhere further. It simply closes the ports adding dialog box, and I'm left with same menu "printer ports"...

 

Any suggestion? Also, I'm running from administrator account, checking a checkbox for setup program "run as administrator". Also, I'm trying to run in "backward support" with "Win XP" - no success...

 

Please help. Thank you in advance

0 Kudos
1 Reply
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Printer WorkCentre 5020 not working/can't (re)install (Win7/10). No USB-printer port available

It's a USB device, so if the cable is good and the port is good, Windows absolutely will see it.

And since Windows will see it, and you don't have it listed as a printer, it will have to be showing as something in Device manager, and since it appears there, there is no reason you can't simply right-click it and use the INI file to install it

Screenshot for reference only since I don't have a USB printer, especially a non-functioning one to show.

1.JPG

 

But since it just stopped working as you implied, and doesn't work on 2 very different Windows OS's (7 and 10), my guess is the printer or the cable is bad.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
0 Kudos