cancel
Showing results for 
Search instead for 
Did you mean: 
DebSki
New Member
New Member

Printer not being recognised by PC

Product Name: Phaser 6600
Operating System: Windows 10

Hi

I have had this printer for a number of years & it's been great. However, when I tried to print last week, nothing happened. I can only assume that a) the printer has broken or b) there's a problem with Windows - I believe it's the latter.

I have USB001 available (I understand that was a problem with a recent Windows update)

My PC appears to not recognise that I have a printer connected.

I have been on Microsoft webchat for over 2½ hours & didn't get a result

I have uninstalled printer & reinstalled.
I have spoken to Xerox tech support & gather that I have the latest drivers (also Windows tells me that)
I have deleted all USB drivers & reinstalled by restarting PC
I have tried a different USB cable in a different port
I have tried connecting the printer to a different PC - prints just fine
I have a couple of times managed to get the printer to print a test page by changing the security settings within printer properties - gave all users listed access to print, manage this printer & special permissions - got all excited, but a) couldn't print a second test page & b) couldn't print anything else.
I have rebooted PC I don't know how many times
I have done a clean boot - made no difference
I have restarted printspooler I don't know how many times
I have checked for temp print files from C:\Windows\System32\spool\PRINTERS (folder empty)

I have spent hours on this & getting nowhere. Am at a loss to know what to do next.

Could it be a problem with winprint.dll? Could it be a problem in the registry?

I did another Windows update this morning to see if that fixed the problem. It didn't

Does anyone have any ideas??

My next line of attack is to bring home another printer that I know is Windows 10 compatible. However, I am reluctant to do that as the printer I have available weighs about 30Kg & I don't really want the aggravation of having to lug it in & out of the office/car/house etc.

Thanks in advance

Tags (1)
0 Kudos
1 Reply
CherylO-Xerox
Community Manager
Community Manager

Re: Printer not being recognised by PC

Hi DebSki, 

Thank you for using the Support Forum. Please take a look at this post.  The poster had some similar issues and you may be able to use some of the solutions they tried.  I know it is a different version of Windows but some of the solutions may translate to Win 10.  If this does not help, please consider contacting your support centre for further assistance and asking to speak with someone in 2nd level.  

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!