cancel
Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

Problems with Global Drivers!

We use Global Drivers on our Server 2008 x64. When a network-client tries to map the printer everything seems fine. But when they try to print, og try to click "properties" on the printer...it fails with error "function address 0x4c03d94b caused a protection fault".

I've tried to update the driver with no luck. When I log in on the client as an administrator and map the printer everything works FINE (and a user can then log on and use the printer without errors). But when a regular user with no admin-rights logs on and try to map the printer...the error occurs.

 

Seems like the driver (version 5185.1900 and/or 5185.3200) tries to create a folder in c:\windows\system32\spool\driver\w32x86\3 called "Xerox". Of course this fails when the user is a non-admin.

 

Any idea about this???

0 Kudos
3 Replies
Highlighted
Valued Advisor
Valued Advisor

Re: Problems with Global Drivers!

there is a problem with your network then , client (non-admin) users should be able to write in that folder, since that folder is the directory for ALL printers , not only xerox creates there folders....

 

Maybe you put an ntfs security in it?

 

I installed 5.185.32 yesterday with a roll out of 600 clients with an sbs2008 as print server with no problem...

0 Kudos
Highlighted
New Member
New Member

Re: Problems with Global Drivers!

I've seen this problem just yesterday, and it's annoying. I see you've said that you've tried updating the driver, but have you fully removed it from the server (delete printer, restart print spooler, click any other printer installed, click Print Server Properties, Drivers, and then select the driver, and delete and remove package) 

 

once that has worked, restart the print spooler again, and attempt to reinstall the driver. 

 

I've seen this when users have had admin rights. yesterday, i tried a different driver (luckily the machine was both PS and PCL) and that had no issues, the client there was win 7 x64, so it could be a bug in a specific driver. 

 

 

0 Kudos
Highlighted
New Member
New Member

Re: Problems with Global Drivers!

Polarman, or anyone else for that sake.

Have you been able to resolve this issue?

At one of our clients we recently introduced the function address error too on their citrix servers which are running server 2008 R2 . Strangely enough, it only starts appearing after a few days. A reboot seems to resolve the problem for some time again.

We are using the latest version of the xerox global print driver PCL 6 Version: 5.347.6.0 (x64) 

A roll back is not a solution since we will then lose support on some new multifunctionals, a daily reboot schedule seems the only thing we can do but we would like to avoid that.

Any suggestions would be most welcome.

0 Kudos