cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

Samsung Galaxy Note8 Cannot Connect to Phaser 3020 Printer

Product Name: Phaser 3020
Operating System: Android

I'm trying to connect a Galaxy Note8 purchased in the US with a Phaser 3020 bought in Bulgaria (a Xerox representative in the US told me that the place of purchase may make a difference) via Wi-Fi Direct. My iOS devices connect just fine. I made all the necessary steps on the Galaxy: Settings->Connections->More connection settings->Printings->Xerox Printing Service and many other services. Xerox Printer Services cannot discover the printer. Tried it with the IP of the printer. No cigar. With the Default Printer Service->Find Wi-Fi Direct printers I reach the point whereby the printer is found judging by the message "add DIRECT-Nv Phaser 3020". Tapping on it invokes a message Connecting to DIRECT-Nv Phaser 3020 and the printer seems to start crunching for a sec. After that a message appears saying "You may need to approve this connection on your printer's front panel" followed by "Could not connect to DIRECT-Nv Phaser 3020". Apparently, the approval by the printer failed but I have no clue how to grant that approval. Tried pressing the two buttons in various combinations to no avail. Is there a way to connect this printer with the Galaxy or they are intrinsically incompatible?

0 Kudos
2 Replies
Highlighted
Community Manager
Community Manager

Re: Samsung Galaxy Note8 Cannot Connect to Phaser 3020 Printer

Hi koooyyy,

Thank you for using the Support Forum. Please take a look at the wireless section in the user guide. Also review the solution for configuring wi-fi direct. If these sources do not help please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Highlighted
New Member
New Member

Re: Samsung Galaxy Note8 Cannot Connect to Phaser 3020 Printer

Hi, I have exactly the same problem as above. Can you assist, please?

0 Kudos