cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
PartTimeGeek Frequent Member
Frequent Member

Server-Based Global Print Drivers with GPO only partially deploy to workstations

Hi All,

 

This is a cross-post of the end of a discussion from here:

http://forum.support.xerox.com/t5/Printing/Global-Print-Driver-In-Place-upgrade-of-Non-Versioned-dri...

 

Joe was very helpful in pointing me in the right direction on how to use the XML tool to set configurations for Server Deployed drivers and Group Policy deployment.

 

My renewed interest in this old thread was predicated by the purchase of a (most excellent, by the way) brand new Xerox VersaLink B405 DN as an addtion to rather than a replacement for one of our two existing Xerox MFCs

 

We have the ColorQube 9303 and an older WorkCentre 3550

 

All PCs printing to the ColorQube and WorkCentre are using locally-installed and configured GPD drivers

 

Though I began a push last year to uninstall any that were instantiated as versioned and reinstall them as Non-Versioned, I have not completed that process.

 

Further, all of the existing locally-installed GPD deployments whether instatiated as Versioned or Non-Versioned, were from these two installers:

X-GPD_5.469.9.0_PCL6_x64.exe

X-GPD_5.469.9.0_PS_x64.exe

 

With the new VersaLink, rather than giving in to the pressure of doing what I know, and going to each PC and running the installer and configuring it separately, I decided that people can wait until I do this right, and do it in a way that will utlimately save huge amounts of redundant work, and keep all the xerox print drivers in lockstep and easily upgraded to the latest versions.

 

Environment:

  • Active Directory domain where the newest version of windows for any of our member servers or DCs is 2008 R2
  • We have a Server 2008 R2 VM which serves as a network management platform, running Spiceworks, WSUS, Our remote consoles for StorageCraft ImageManager and ShadowProtect SPX management, etc.
  • Windows 7 Professional 64bit on all workstations (no laptops in our environment for all intents and purposes)
  • Symantec Endpoint Protection centrally managed and hosted from a dedicated Server 2008 R2 VM, and running on all PCs
  • Gigabit Ethernet backbone on a flat subnet

Plan:

  • Install Print Management role on said Network Management VM
  • Install the new B405 printer driver with both PS and PCL6 queues in Non-Versioned mode on that server using driver installer UNIV_5.520.6.0_PCL6_x64.exe and UNIV_5.520.6.0_PS_x64.exe
  • Share them and list in directory
  • Go to Advanced tab on the server queues printer properties dialog and set the Printing Defaults as we would like them to be at deployment time on end user PCs
  • Configure it so end users can later change their own printing preferences defaults in Devices and Printers
  • Deploy the the printer drivers, queues, and defaults using GPO, on a per Computer (not per user) basis.
  • Expectation being that any existing locally installed 5.469.9.0 Non-Versioned GPD queues for the ColorQube and WorkCentre would all pick up the 5.520.6.0 driver as it will have replaced the 5.469.9.0 one by nature of how Non-Versioned works
  • In future, deploy queues for the ColorQube and WorkCentre  with separate GPOs as well, go desktop by desktop and remove the locally-installed queues for said, and add those Computer objects to an OU containing the new GPOs to deploy them one by one
  • Live happily ever after never having to touch a PC again when it is time to upgrade drivers or replace the horrid ColorQube 9303 with a pretty AltaLink when our lease is up.

 

 

Here’s where I am at:

 

  • I did not have the plan distilled as completely as above when I started the following baby steps, but here goes
  • "First test case PC" has a locally installed Non-Versioned GPD version 5.469.9.0 PCL6 and PS driver each pointing at our Workcentre 3550 and ColorQube 9303 (4 existing queues total)
  • Using Active Directory User and Computers, I created a new Organizational Unit (OU) named XeroxGpdQueues subjugate to the “Computers” Built-In OU
  • Moved the computer object for said test case PC from Computers OU to XeroxGpdQueues
  • I installed the Print Management Role on our Server 2008 R2 management server VM
  • Installed the Non-Versioned PCL6 and PS Global Print Drivers (v 5.520.6.0) on the (now) print server
  • Configured the Advanced tab | Printing Defaults the way I wanted all the drivers on the network to be deployed (1 sided, ID print on banner page)
  • From the Print Management console, shared them, with “render print jobs on client PCs” and “List in the directory” checked.
  • The first time, I did it to my own pc and was not using the GPO method, I did it by doing Add Printer, Add network Printer, and selected it from the directory.
  • Everything seemed to work ok using that method
  • After that, I tried said  "First Test Case" on a PC with a very simple and relatively new windows image on it.
  • From "the Print Management console, right clicked on each B405 printer and selected Deploy using Group Policy
  • This created a new GPO which I placed in the XeroxGpdQueues OU
  • GPO is per PC and not per User
  • Rebooted the test case computer which now resides in the XeroxGpdQueues OU
  • Printer icons show up after some delay in Devices and Printers, printer connectoid changes to Xerox GPD icon after some time
  • Once the new MFC driver GPO deployment completed the local queues for the ColorQube and WorkCentre were automatically upgraded from 4.3x to 5.520.x
  • This one happened to work, it got the new drivers, and all the defaults were there, all of the pulldowns were present in the print preferences dialog box.

 

I began adding other PCs to the XeroxGpdQueues

  • On a couple of the PCs one of them, say the PS queue’s, printer icon changed to the blue and white Xerox GPD one, but the PCL6 stayed as the default windows 7 one.
  • Neither of the queues (PS or PCL6) picked up the Printing Defaults I set
  • On both PCS, neither queue’s print preferences dialog box showed the picture of the VersaLink B405 yet nor did they have all the pull down boxes for 1 or 2 sided etc
  • Even if I removed them from the OU and rebooted, noticed the printer queues were gone, and then added them back to the OU and watched them re-deploy, the exact same conditions came up.
  • Another one seemed to pick all of it up and the driver completely deployed

 

I figured that the standard Windows Print Management method:

 (the settings made in  "Advanced | Printing Defaults" dictates initial print preferences are set for GPO deployed printers)

might not work with Xerox and that is why the XML tool exists

 

So I tried using the XML method (thank you again)

 

  • Assuming that the string for "Printer Model" described in the XML tool documentation refers to the text you see when you open the GPD driver printer properties Dialog box, Advanced Tab, About | About, I followed the steps in the XML tool documentation to the letter.
  • I Found the same variability in how complete the drivers installed and instantiated themselves
  • This would stay in said state in most cases across reboots of the PCs in questions
  • In some cases, running the troubleshooter on a recalcitrant print queue, WITHOUT taking any of the suggested actions in the troubleshooter, would bring up the full feature set of pulldowns and the picture of the printer on the general tab in the print preferences dialog, but it still would not pick up the defaults I set.
  • I had the CacheExpirationInMinutes set to 0 to make sure the driver was referencing the XML repository every time the dialog box was opened.
  • I had all the preferences Setting Restrictions set to "default", rather than either of the two enforced options

Remaining questions

  • I am wondering if there is something inherently broken in the Server 2008 R2 Print management role and/or Group Policy processing which cuts off the deployment before all the data and remote commands get a chance to process the instantiation of the driver and the defaults?
  • Is this something to do with the Xerox drivers and the conditions I described being a unique case? (in other words if there were no Xerox printers on any of the PCs to begin with, would the b405 deployment have worked with either the Microsoft or the Xerox XML methods in all cases?
  • Is the presence of Symantec Endpoint Protection a known conflictor with GPO deployment of these drivers?

 

What to do next?

  • Even assuming I stop troubleshooting and looking for a root cause and just punt and manually get everything righted: IE: All the ColorQube and WorkCentre locally installed Non-Versioned and Versioned drivers uninstalled manually (including the packages), and re-deployed via Print Managment / GPO (into PCs which now will already have the same driver version)
  • I really am afraid of a situation where I add a 4th Xerox device, at a time when the GPD driver is newer than what is currently deployed.. Is the combination of having to both: replace the GPD driver AND deploy a new queue on the target PC just too much for the Group Policy mechanism to handle to completion?
  • I am feeling like I could remove one varialble from this scenario by first installing (on the print server) the new driver as a second instatiation of the PCL6 and PS B405 print queues using the Non-Versioned GPD driver. This will propagate the driver to the existing server instantiations of the B405 which are shared, and will spill down to all the PCs in the environment. I would clean things up by subsequently deleting the extra instantiations
  • Any thoughts on any of this would be greatly appreciated. I think I will add some tags to this post to increase the audience as well.

 

In searching on the issue, I had found some stuff pertaining to windows 10 clients and windows 2012 (not R2) clients not propagating the defaults and it had something to do with some basic dll’s that are used for PS and or PCL printing being of differing versions on the client and server OSes, etc.

Could not find that particular Microsoft KB again, but here are some discussions that seem to be nebulous at best in terms of what is really going on when this happens

 

https://social.technet.microsoft.com/Forums/systemcenter/en-US/a6e8ad20-3cc2-4137-897f-e92bd5405b9f/...

 

BTW I want the drivers to be deployed on a per PC basis so any user on that PC will have the printer available, rather than per user, but I even tried doing it per user to try to get the problem to go away and it either did nothing or complicated things.

 

Anyway, I need to post this now because I have been editing it for two days trying to make it as succinct as possible, but this stuff is never simple to explain.

 

Again, thanks to Joe for all the help and thanks in advance to any who might be able to help me with this issue.

 

Chris.

 

"Time is an illusion... Lunchtime, doubly so."
-- Ford Prefect
0 Kudos