Showing results for 
Search instead for 
Did you mean: 
ThomasVit New Member
New Member

Splwow64.exe error


Our users are getting all of a sudden the follwing error when they try to print on our Xerox printers:

splwow64.exe -SystemErrorThe program can't start because x2utili6.dll is missing from your computer. Try reinstalling the program to fix this problem.

The users are local admins on their workstation, the printers are mounted automatically by GPO, these are Windows 7 x64 machines, it is affecting not all users (i can print myself without any issue).

I have tried restarting the spooler service and delete the C:\WINDOWS\SPOOLER\PRINTERS files without any luck.

The dll file is located in two places:




The printer is accessed via a Windows 2008R2 print server. I have compared the dll file from a buggy computer with a healthy one, the dlls are exactly the same (same size, same created/modified time, same driver version)

0 Kudos
5 Replies
Kimzi Valued Advisor
Valued Advisor

Re: Splwow64.exe error



Splwow64.exe allows 32bit programs connect to 64bit spoolers on the 64bit system.

When getting this problem its usually a permission issue, try excluding this in ur firewall and antivirus.

If that does not work, what about disabling Client-side Rendering and see if that works?




ThomasVit New Member
New Member

Re: Splwow64.exe error

Actually disabling the Client Side Rendering fixes the issue!

I will see about excluding the process in the Antivirus, maybe this is the real problem,..

0 Kudos
philgman Member

Re: Splwow64.exe error

i've been seeing this around my work. Our situation was a bad batch of x64 universal drivers that were pushed out to some of the desktop users. our current work around is to locally stop the print spooler service and remove the drivers, then restart spoler service and reinstall drivers.

0 Kudos
ThomasVit New Member
New Member

Re: Splwow64.exe error

I disabled CSR, made exclusions in the Antivirus for C:Windows\Splwow64.exe, while it solved the problem for some users, we keep getting the same error for others.


As a quick fix we reimage the computers and all seems fine afterwards.


I dont know where to start looking for a resolution, all i can think of is that it hapens to brand new computers that have SSD drives, i wonder if th efact that these machines boot so fast is making the spooler service trying to get drivers beofre they are unavailable on the network,..

0 Kudos
FDBT New Member
New Member

Re: Splwow64.exe error

This is an old thread, but I know it likely is still hapening to a lot of folks.


We've had this common problem off and on for years now with our Xerox copiers and the Xerox print drivers that are installed via our Windows print server onto the client PCs (our users have no permissions to install printers themselves).  The problem directly stems from the Dependent Files registry entry for the print driver being blank or corrupted on the Windows client PC (Windows 7 64-bit), but I don't know why this registry glitch happens.


When it does happen (and I'll usually get 3 or 4 users a day having this problem), I have a 60 second fix that I do on the client PCs to make them ready to go again (until the next time it happens):


1) Remove the Xerox copiers from the user's list of printers on their PC.

2) RunAs REGEDIT.EXE as an admin user.

3) Delete any Xerox print driver keys that you find under HKLM\System\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3

4) RunAs Services.msc as an admin user.

5) Stop and Start the Print Spool service (or reboot the PC and have the user log in again).

6) Now re-add the Xerox copiers for the user (or you can set up a GPO to automatically add the Xerox copiers when the user logs in).


Printing to the Xerox copier should work now. 


I have been able to apply this workaround remotely too, but the user then has to reboot the computer and login again and then manually re-add the Xerox copier(s), unless you use a GPO to automatically add the copier(s) at login.


0 Kudos