cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

Unable to print with XSA from macOS 10.14 Mojave to WC5150

Product Name: WorkCentre 5135/5150
Operating System: macOS 10.14 - Mojave

I support a few dozen Mac users who have been printing to a heavily-used WC5150 that uses Xerox Standard Accounting.  Many of these users have recently been upgraded to macOS 10.14.6 Mojave. 

The WC5150 is apparently supported on macOS Mojave per this Mojave compatibility document: https://www.xerox.com/downloads/dl/usa/en/m/macos_mojave_compatibility_02_07.pdf

BUT, the actual experience that these users are having is that they cannot print to the WC5150 on Mojave because they are never prompted for XSA accounting codes.  The XSA prompt does not come up automatically when printing from ANY app (Word, Acrobat, Preview, you name it) and the "Xerox Features" menu does not exist in any app either, only "Printer Features", which does not have a place to enter the XSA code (again, in all apps.)  So all jobs to this printer are failing.  In addition if I go into System Preferences -> Printers, the window for the WC5150 says "You need to install software to use this printer."

The driver package we are currently deploying is Xerox Printer Driver 4.14, which is the most recent one for the WC5150 on Xerox's website.  When searching for drivers, you can select macOS 10.14 as the OS for WC5150, but no drivers come up -- so the 4.14 driver is actually for macOS 10.13 (why is there no WC5150 driver for macOS 10.14 if the OS is considered "supported"?)

We also have some newer Xerox printers for which Xerox Printer Driver 5.2 is the latest driver.  When I install driver 5.2, the situation is exactly the same with respect to the WC 5150, no change.  Both the 4.14 and 5.2 drivers seems to work fine with respect to XSA on macOS 10.13 High Sierra.  But again, I have more and more users on Mojave.

So what is going on here?  Is the WC5150 not actually supported on macOS Mojave, in direct contradiction what the compatibility document says?  Or is a new driver going to be released that allows XSA to work between Mojave and the 5150?

0 Kudos
1 Reply
Highlighted
Community Manager
Community Manager

Re: Unable to print with XSA from macOS 10.14 Mojave to WC5150

Hello modus,

If you check the compatibility doc:

https://www.xerox.com/en-us/about/printer-driver-update

It says it is compatible with Mojave. I would recommend troubleshooting this with our Support Department. The Support options for your device are listed HERE. 

Thanks,
CathyO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!