cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

WorkCentre 6015 not compatible with MacOS 10.15 Catalina

I recently updated my laptop to MacOS 10.5 Catalina and just curious as to how I can get the Xerox driver to work. I did read the Product Compatability document and it does state that WorkCentre 6015 is not supported by Catalina and since there isn't a drive available for Catalina, I tried downloading both the Mojave drivers (Xerox WorkCentre 6015B 64bit Mac 10.12, 10.13, 10.14 and Xerox WorkCentre 6015N_NI 64bit Mac 10.12, 10.13, 10.14) but every time I try to open the downloads, I get a message saying,

Xerox WorkCentre 6015N_NI installer.pkg can’t be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information." 

If someone can help me out on how to get it to work, that would be great! I'm literally in the middle of printing something important and having to find out that my printer isn't compatible anymore with my newly updated laptop is really frustrating. I don't find it reasonable to buy a new printer while still having a printer that's working perfectly fine. What can Catalina users do other than buying a new printer? Do we have to wait until the next update comes out or is this the end of WorkCentre 6015?

8 Replies
Highlighted
Community Manager
Community Manager

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

Hello eliasmai,

If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: WorkCentre 6015.

Alternatively, you can visit our Contact Us page for other support options

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Highlighted
Member
Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

0 Kudos
Highlighted
New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

I used the Mojave driver and it worked.

Link to Mojave Driver 

Highlighted
New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

OK, I am a little puzzeled with the suggestions offered by Xerox - there is nothing within the Xerox knowledge base that shares the exact "solution"

So, are you going to provide a the update needed for Catalina or not?

 

The suggestions do not work and there is NOTHING listed within the Xerox list of current drivers for the 6015 printer

(If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: WorkCentre 6015.

Alternatively, you can visit our Contact Us page for other support options

Thanks,
CherylO-Xerox
Community Manager)

 

After updating to Catalina; it is really not a easy option to go back to the previous Mac OS - the link to the Mojave driver didn't work, I tried it since it was suggested to do so

 

....and I have at least $300 of color ink for my printer that used to work perfectly and now all of this ink is worthless

 

If all of us who own Xerox 6015 are SOL; then just tell us

 

CherylO, am I missing something?

 

please help

New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

I have not updated to Catalina because of the same problem with Workcentre 6015.  Does anyone have a printer bypass solution or Global print driver.  I tried to download the one from Xerox but can't do it.

Thanks

Marlene

0 Kudos
Highlighted
New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

0 Kudos
Highlighted
New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

I had the same problem and spent so much money on colour toners just to find out that the driver was not compatible! However, they have now made a driver that supports macOS 10.15 Catalina https://www.support.xerox.com/support/workcentre-6015/downloads/enus.html?operatingSystem=macOS10_15
Hope this helps!
0 Kudos
Highlighted
New Member
New Member

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

Xerox released a new driver that supports macOS 10.15 Catalina and it works for me now
https://www.support.xerox.com/support/workcentre-6015/downloads/enus.html?operatingSystem=macOS10_15