cancel
Showing results for 
Search instead for 
Did you mean: 
eliasmai New Member
New Member

WorkCentre 6015 not compatible with MacOS 10.15 Catalina

I recently updated my laptop to MacOS 10.5 Catalina and just curious as to how I can get the Xerox driver to work. I did read the Product Compatability document and it does state that WorkCentre 6015 is not supported by Catalina and since there isn't a drive available for Catalina, I tried downloading both the Mojave drivers (Xerox WorkCentre 6015B 64bit Mac 10.12, 10.13, 10.14 and Xerox WorkCentre 6015N_NI 64bit Mac 10.12, 10.13, 10.14) but every time I try to open the downloads, I get a message saying,

Xerox WorkCentre 6015N_NI installer.pkg can’t be opened because Apple cannot check it for malicious software. This software needs to be updated. Contact the developer for more information." 

If someone can help me out on how to get it to work, that would be great! I'm literally in the middle of printing something important and having to find out that my printer isn't compatible anymore with my newly updated laptop is really frustrating. I don't find it reasonable to buy a new printer while still having a printer that's working perfectly fine. What can Catalina users do other than buying a new printer? Do we have to wait until the next update comes out or is this the end of WorkCentre 6015?

0 Kudos
1 Reply
Community Manager CherylO-Xerox
Community Manager

Re: WorkCentre 6015 not compatible with MacOS 10.15 Catalina

Hello eliasmai,

If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: WorkCentre 6015.

Alternatively, you can visit our Contact Us page for other support options

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!