cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
pcdudept New Member
New Member

WorkCentre 6505 Imaging Unit error

Hi,

 

We have a WorkCentre 6505 in which the imaging unit had to be replaced but with two different new imaging units it is always showing error message "091-912 - Imaging Unit Error - Remove Imaging Unit and Confirm all Yellow Ribbons"

We've checked that all 8 yellow ribbons (protective labels) have been removed correctly.
These two new imaging units work just fine in another WorkCentre 6505, so it seems to be a problem with any kind of sensor or anything else on the printer that might be causing this problem.

 

Can someone help with this problem?

 

Thanks and regards.

0 Kudos
4 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: WorkCentre 6505 Imaging Unit error

Have you checked inside the machine for pieces of paper or one of those yellow ribbons that may have come off the first device and stayed in the machine when the device was removed? Just about anything that could cover the sensor would make it believe there was a yellow ribbon in there.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
pcdudept New Member
New Member

Re: WorkCentre 6505 Imaging Unit error

Hi Joe,

 

Yes, I've checked and there are no pieces of paper inside the printer or pieces of the yellow ribbons.

Can you please inform where the sensor is located in the printer so I can check it better?

 

Thanks and regards

0 Kudos
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: WorkCentre 6505 Imaging Unit error

Sorry, I do not know where they are.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
0 Kudos
pcdudept New Member
New Member

Re: WorkCentre 6505 Imaging Unit error

With the old Imaging Unit the printer does not display the 091-912 error, only a message saying the IU should be replaced but it goes online and we are able to scan documents with it.

Shouldn't it show the same error message if it was a sensor error or some kind of dust or paper piece in the sensor?

0 Kudos