cancel
Showing results for 
Search instead for 
Did you mean: 
cebctx New Member
New Member

WorkCentre 6655 brand new giving error "Please wait... Adjustments are in progress."

Just purchased a brand new Xerox WorkCentre 6655 a few weeks ago. Unwrapped it, unboxed it, installed the drivers and the web interface for it and even registered it with Xerox. A few hours later it gives the message "Please Wait... Adjustments are in progress. System Error. Power Off then On and Notify System Administrator."

 

Needless to say powering it off then on did not do anything. Looking at the fault codes I see 392.670.00 but this fault code is not listed on the WorkCentre 6655 Support page fault code search. 

 

No amount of Google fu could help me find the root of this fault code. I called Xerox support and the support that handles this printer is supposedly only 8AM-5PM Mon-Fri. The support page for the printer said 24x7 but whatever.

 

It's a brand new printer and giving a cryptic fault code is causing nothing but a headache. Any assistance would be much appreciated.

0 Kudos
2 Replies
Kimzi Valued Advisor
Valued Advisor

Re: WorkCentre 6655 brand new giving error "Please wait... Adjustments are in progress."

Hi, Cebctx!

 

It's a yellow imaging unit failure.

What you can do is:
• Reseat the affected Imaging Unit.
• Check the Imaging Unit is the correct part number for this model.
• Check Transfer Belt installation.
• Cycle system power.

If the problem persists I suggest you call Xerox and ask them to fix it as this is a new unit.

 

Best Regards

Kimzi


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.

fiery Occasional Advisor
Occasional Advisor

Re: WorkCentre 6655 brand new giving error "Please wait... Adjustments are in progress."

Kimzi is correct. Probably a yellow toner dispensing problem or IBT assembly.