cancel
Showing results for 
Search instead for 
Did you mean: 
rdaniels2 Valued Contributor
Valued Contributor

XPS option not installed on WorkCentre

Product Name: WorkCentre
Operating System: Not Applicable

I ran into this issue a couple of times and always redirect users to a different printer. Because I never knew where to look because of an error print stating that the XPS Option isn't installed. Today, when researching a different issue, I noticed that on some devices the option is installed and some devices the option isn't installed.

Is there a way to enable this option on the devices that states "not installed" ?

We use the Xerox Global Driver for all Xerox devices.

Randy
Please be sure to select Accept Solution and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!
0 Kudos
2 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: XPS option not installed on WorkCentre

You certainly can enable it, but it isn't free, you have to go through sales to get it.

You do not get the message in the Xerox GPD, there is no XPS GPD, you get it by installing an XPS driver (maybe 5% of the cases) or the Microsoft Class drivers (the other 95%)

And I bet you did not even mean to install the class driver, or you did, and MS converted it later, which will happen in 2 very common scenarios.

1. First is you install the printer and choose it from the list instead of manually creating the port (the printer that I want isn't listed), if you do this, MS will ever so helpfully use a WSD port, and if it does, it will on the next reboot decide that the Class driver is better, and will switch you to that, and then you get the XPS error.

1.JPG

 

2. You install the driver and leave this option checked, in which case, even if the Wizard is initiated from a Xerox installer, it will always choose the Class driver, because MS chooses MS over the manufacturer

2.JPG

My guess is that number 1 is your issue, simply because I assume you install the driver, send a print, it works, and then the user states they get a fault later, which makes sense in scenario one where MS converts it after the install, typically on the next reboot.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
rdaniels2 Valued Contributor
Valued Contributor

Re: XPS option not installed on WorkCentre

Joe,

I am trying to figure out like an issue that I posted before about accounting code prompt, that this might be a driver that is either older or newer then the one, that is suppose to be used. And is causing some people to get this XPS error.

I am not the one that installs the drivers on the Print Server, so when I remove the printer / Drivers for the affected machine, and re-install them. Option 2 technically should be the way its getting installed.

I am also going to bring this up to my onsite Xerox technician as well, Just to see if this option is suppose to be enabled on our devices.

Thanks for the Help.

 

Randy
Please be sure to select Accept Solution and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!
0 Kudos