Showing results for 
Search instead for 
Did you mean: 
3 Replies
New Member
New Member

Re: Xerox B210 doesn’t work under Linux (with CUPS)

I just noticed these comments and do not have the time at the moment to respond more. However, I can testify the B210 does, indeed, function under linux (I am using ubuntu at present, but have also used CentOS and Manjaro and perhaps another), but apparently not fully. It is less than satisfactory as far as I am concerned. For example, it seems to have trouble properly utilizing envelopes (not handling, but accepting envelopes from the manual feed rather than the sheets in the primary tray) as well as any custom defined paper (tried to get around envelope problem) of that size. I have it connected to a router (ethernet) and I connect wirelessly, through that router. I believe I have also used usb, but do not recall clearly. My print manager recognizes the printer - too well, as I had a problem with multiple instances of the same printer. I provided CUPS with the PPD, which I believe I extracted from the Xerox software.

At present I have a problem with duplex printing not being recognized, though I do not know if that has to do with the application or the printer. It doesn't happen all the time.

I hope this provides some hope!

0 Kudos

Re: Xerox B210 doesn’t work under Linux (with CUPS)

Did you ever get anywhere with this? I am in exactly the same boat and don't seem to find a solution anywhere. I can get the printer working on windows as USB thats it.
0 Kudos

Re: Xerox B210 doesn’t work under Linux (with CUPS)

So, this printer does not support printing via USB, unfortunately. Neither on Linux, nor on Windows. It does have some presence on the USB bus and is identified, but won’t work. Not sure if I have a broken specimen or if it’s meant to be that way.

Unfortunately, printing over Ethernet does not work either. In other words, this printer does not print anything other than its own configuration page.

(I don’t want to print over Ethernet, ever, for security reasons, but bit the bullet and connected the printer via a dedicated USB / Ethernet adapter.)

Well, at least I can connect to the printer’s web interface, which works just fine (and claims that USB is enabled, which does not seem to be the case).

However, there is no way to print. CUPS does detect the printer on the network (over DNSSD) and can also configure it via IPP, but all attempts to print simply say Filter failed.

My level of frustration is through the roof at this point and I have to ask the obvious question: Is this printer actually supposed to print on at least one operating system via at least one connection type?

0 Kudos

Xerox B210 doesn’t work under Linux (with CUPS)

Product Name: Xerox B210 Printer
Operating System: Linux

Is there a way to make Xerox B210 work (on USB) under Linux with CUPS? It simply doesn’t work in my case.

I filed a detailed bug report with logs, package versions and lots of further information.

It seems to me that the installation script from Xerox is incompatible with current CUPS and therefore does nothing. The printer won’t get auto-detected by CUPS, no matter if the drivers from Xerox are installed or not.

Is there a way to manually derive a printer URI (something like usb:/Xerox_B210_Series?serial=3438009620) and strongarm CUPS into using it despite the failing autodetection? (Presumably, this URI does not work.)

Any ideas? The bug report linked above lists what I’ve already tried (disabling usblp etc.).

0 Kudos