cancel
Showing results for 
Search instead for 
Did you mean: 
valentind New Member
New Member

Xerox Color C60/C70 with EX-i C60/C70 Print Server for Linux Client

Hi,

 

I own in my association a "Xerox Color C60/C70 with EX-i C60/C70 Print Server", it also uses Fiery system. We use free software a lot, especially CUPS for printing because we have another xerox printer.

On Arch Linux & Debian, CUPS (thanks to Avahi package) detects the printer in my network but when I finalize adding, it says to me :

 

Unable to add printer:

Unable to copy PPD file.


This is because in a list, the only possibility to continue adding printer is "Xerox EX-i C60-C70 Printer (EU), driverless, cups-filters 1.20.3 (en)".

I have a lot of other models available to add in the list(Phaser, Workcentre, Docuprinter, etc...), I know sometimes you can use a different model on CUPS and it does work fine too... I am really not sure for this one so here is my question :

Do you know a way to make a ppd file from Windows or Mac OS X installers for my printer or is there a way to recover .ppd file for CUPS ? (I didn't find any .ppd file in drivers download page of Xerox EX-i C60/C70 page)

 

Thanks a lot,
Valentin

0 Kudos
1 Reply
Analyst Nation Moderator Joe053204-xrx
Analyst Nation Moderator

Re: Xerox Color C60/C70 with EX-i C60/C70 Print Server for Linux Client

Xerox supports linux so we have Linux drivers for our C60/C70.

 

EFI (The makers of the Fiery) only support Windows/Mac. But there are options:

 

1. Setup all the job attributes in a Virtual printer, then print to that Virtual Printer (using LPR) and a generic PostScript (PS) driver. Good if you usually used a fixed set of options, or a few fixed sets so you can setup one Virtual printer per set.

2. Install the Xerox Linux driver using RAW/HP Jet direct port and change the port to 9200 (It will bypass the Fiery entirely)

3. Print via PS driver to the Fiery Hold queue, and then from there apply settings in Command Workstation before printing. It's an extra step, but you get all the options available.

 

4. Grab a Windows driver, extract it and browse to EXi_PrintDriverPA.zip\PRNTDRV.EXE\Ps_drvr\Common\English\ to grab the PPD's and other files you may need <untested by me>

 

Capture.JPG

 

You may be able to do number 4 with a Mac driver instead of Windows (Especially since it would already use CUPS), but I have not tried it and am not sure on the process.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
0 Kudos