cancel
Showing results for 
Search instead for 
Did you mean: 
illan New Member
New Member

looking for older global Print Drivers

Grettings,

 

im looking to download an older version of the global print Driver. the current one the website is not working for our printers. anyway to get earlier versions?

0 Kudos
11 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: looking for older global Print Drivers

Which version did you need?

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
0 Kudos
illan New Member
New Member

Re: looking for older global Print Drivers

2014 and 2015  version. sorry for the delay

illan New Member
New Member

Re: looking for older global Print Drivers

we have a workcentre m20 ans a workcentre 24. the current pritn drivers do not work

however a older pc has an old driver and it works flawlessly

0 Kudos
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: looking for older global Print Drivers

Without a specific driver version and Operating system in use version I am left with randomly linking a driver from the 13 versions released per architecture(x86/x64) and type (PS/PCL/PCL6)

 

So here is the x86 PS GPD version 5.303.17.5 non-WHQL

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
mcbroken New Member
New Member

Re: looking for older global Print Drivers

I have the same issue, M20 does not print right with current drivers.  I think I need older than 5.3, running 64bit.

0 Kudos
Highlighted
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: looking for older global Print Drivers

5.303.16.0 x64 PS

5.303.16.0 x86 PS

5.303.16.0 x86 PCL

5.303.16.0 x64 PCL

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
mcbroken New Member
New Member

Re: looking for older global Print Drivers

Thanks!  I will try this and let you know!

 

0 Kudos
mcbroken New Member
New Member

Re: looking for older global Print Drivers

Still printing tons of pages with !PS-Adobe-3.   Pscript_WinNT_ErrorHandler 5.0.0 Suggestions?  I think I need an older driver.

0 Kudos
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: looking for older global Print Drivers

Or you have a printer with no Postscript handler and need to be installing the PCL version

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe