cancel
Showing results for 
Search instead for 
Did you mean: 

"Error - Printing" on Windows but printing works on MACs

Product Name: Other - specify product in post
Operating System: Windows 10 x64

Hello all!

We currently have two different Xerox printers in our office:

WorkCentre 6027

WorkCentre 3215

We used to have no issues printing for either model. However, for the past month or so, we have been unable to add any new computers to the printers. We install the drivers downloaded from xerox.com, as we were before, and it looks like the printers are successfully added, but whenever we try to print, we get "Error - Printing" (see image)

error printing.png

There are two things that are kinda strange about this issue.

1) Windows 10 PCs that we connected before we started having issues are still able to successfully print to the models listed above. It's only new Windows computers we try to connect to the printers that are having issues printing.

2) We have been successful in adding MAC PCs and printing from them to the models listed above, as recently as today. We have had no problems connecting any MACs to the printers.

I'm unsure of where to get any codes, but I've tried a few solutions to resolve the printing, including:

- Stopping and restarting the Print Spooler service

- Powering off/on the printer itself

- Trying to update drivers through Computer Management (says they're up-to-date)

- Deleting the files from \Windows\System32\spool\PRINTERS

Anyone have any ideas on what else we could try, or what could potentially be causing the issue? Thanks for any advice!

The process we were doing for Windows PCs was:

1) Download the Windows 10 x64 driver from https://www.support.xerox.com/en-us/product/workcentre-6027/downloads?platform=win10x64&language=en (we would select the top option, Xerox WorkCentre 6027 Driver x64 bit Installation Package)

2) Run the file and Install

3) After the files were successfully extracted, select "Install Software"

4) Accept the terms

5) Select Network Installation

6) The installation software would successfully locate the printers in our network. I would select which ones I needed, install the drivers, and restart the computer if needed.

0 Kudos
3 Replies
CherylO-Xerox
Valued Advisor
Valued Advisor

Re: "Error - Printing" on Windows but printing works on MACs

Hi iamjustanitguy, 

Thank you for using the Support Forum. Sounds like you have tried everything already, so it would suggest contacting support: 1-800-821-2797 or 1-800-835-6100 

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

alinabo12
New Member
New Member

Re: "Error - Printing" on Windows but printing works on MACs

The folder for source .ppd files (in .gz format) is found in /Library/Printers/PPDs/Contents/Resources

When you install a printer a .ppd is generated for that printer, this is what gets modified if you change default settings in CUPS, and those are found in /etc/cups/ppd

You'll need to show hidden files to see the etc folder while Library should not be hidden, but will require an admin account to work with files within the subfolders.

0 Kudos
johnsons
New Member
New Member

Re: "Error - Printing" on Windows but printing works on MACs

Actually I managed to figure out how to solve this. I found a post on a Microsoft forum on how to delete printer ports by deleting registry keys. How to delete unwanted TCP/IP Printer Ports (microsoft.com). I adapted this technique to delete the two WSD ports, then I selected the TCP/IP port with the proper IP address. The driver then created a new WSD port but it worked. I tried printing various things and it all works fine now.

0 Kudos