Showing results for 
Search instead for 
Did you mean: 
1 Reply
Valued Contributor
Valued Contributor

Re: "printer is unreachable at this time"


make sure that you assigned a static IP address to the printer not DHCP.


  • Double-click the downloaded Xerox Print Driver.dmg and then launch the Xerox Print Driver.pkg
  • Click Continue to move through the installation wizard
  • Click through the prompts to "Agree" to the terms and "Install"
  • When prompted, enter your computer's passworXeroxSetup_05.png
  • After installing the printer driver the Printers and Scanners window should open where you can add the Xerox printer. 
  • If you need to open the Printer and Scanners window later, you can locate it by going to System Preferences then Printers and Scanners.

Add the printer by either printer name or by the IP address:

  • Click the ‘+’ to add your printer and select the ‘IP’ tab.
  •  add the printer’s IP address in the ‘Address’ field.
  • Ensure the ‘Protocol’ field is set to ‘Line Printer Daemon - LPD’
  • type the Queue name "lp"
  • The ‘Use’ field should auto populate the correct printer type. The computer will search for the appropriate driver to use, which may take a few seconds to populate. xerox mac.png


New Member
New Member

"printer is unreachable at this time"

Product Name: WorkCentre 3215
Operating System: macOS 10.15 Catalina

1. Bought new modem/router. I successfully connected the printer to the new wifi. 

2. On my laptop, in System Preferences/Printers&Scanners, I clicked the Add (+) and located the printer. When I highlight the printer, it shows the following:

Name: Xerox WorkCentre 3215 (XRX9C934E43CBED)

Location: [blank]

Use: [dropdown menu with following options]:  AirPrint / Generic PostScript Printer / Generic PCL Printer

3. I add the printer. I don't know which option to choose for "Use", so I have tried all 3.

4. When I try to print something, first it says "connecting to printer" but then it times out and says "the printer is unreachable at this time."

I've rebooted both laptop and printer several times after trying each one of the options above in #3.

I have also tried downloading and installing new drivers from the xerox website but I have no idea what I'm doing after I install them.

The printer has worked fine for years; it was only after I reconnected it to a new modem/router that it's stopped working.

Thanks for any suggestions




0 Kudos