cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

xeroxprtmgr stops working with Xeroxv5Pkg-Linuxx86_64-5.20.626.4179.rpm

Product Name: VersaLink® C500 Printer
Operating System: Linux

Printer is on System 61.31.81

21:34 prtsys % rpm -qa | grep -i xerox
XeroxPrtDrv-5.20.626.4179-1.x86_64
21:34 prtsys % pwd
/opt/Xerox/prtsys
21:34 prtsys % ./xeroxprtmgr  
/builddir/build/BUILD/gcc-8.1.1-20180712/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/i
nclude/bits/basic_string.h:3975: std::basic_string<_CharT, _Traits, _Alloc>::reference std::basic_s
tring<_CharT, _Traits, _Alloc>::operator[](std::basic_string<_CharT, _Traits, _Alloc>::size_type) [
with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::basic_str
ing<_CharT, _Traits, _Alloc>::reference = char&; std::basic_string<_CharT, _Traits, _Alloc>::size_t
ype = long unsigned int]: Assertion '__pos <= size()' failed.
21:34 prtsys %

The printer absolutely works; it was working fine with xeroxprtmgr it will print a page from the console, it will print a PDF from the web interface (so the network connection works!); the defaul CUPS driver connects and will make the C500 spew pages by sending it PCL 3.  I have no idea what the xeroxprtmgr error means.

I'm using Fedora 28, kernel 4.17.14-202.fc28.x86_64

0 Kudos
2 Replies
Highlighted
Community Manager
Community Manager

Re: xeroxprtmgr stops working with Xeroxv5Pkg-Linuxx86_64-5.20.626.4179.rpm

Hello graydon.

 

If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: VersaLink® C500 Printer.

Alternatively, you can visit our Contact Us page for other support options.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
Highlighted
New Member
New Member

Re: xeroxprtmgr stops working with Xeroxv5Pkg-Linuxx86_64-5.20.626.4179.rpm

Hi, I had the same issue with another printer model, solved by updating the driver from 5.15.551.3277 to 5.20.647.4414.

Interestingly enough, a very similar issue emerged with another unrelated software in Fedora 29 (solved by building from source). I suspect it's because of changed ABI coming with gcc 8 (https://www.gnu.org/software/gcc/gcc-8/porting_to.html).
0 Kudos