Showing results for 
Search instead for 
Did you mean: 
5 Replies
New Member
New Member

Re: Workcentre 7855 Accounting + Linux = Problems

Jump to solution

I'm trying to get accounting set up on the following system, to print to a Xerox WorkCentre 7855. I'm having trouble configuring the PPD file to hard code the user's ID in it.


Computer: Dell XPS

Procesor: Intel® Core™ i7-5500U CPU @ 2.40GHz × 4

OS type: 64 bit


OS: Ubuntu 16.04 LTS


Linux print drivers (etc.) for Xerox WorkCentre 7855




1) Which installer should I use?


Apr 27, 2014 v. 5.15.540.3080/Xeroxv5Pkg-Linuxx86_64-5.15.540.3080.deb (Shown as "recommended" on the site.)




Jan 1, 2018 v. 5.20.620.4098/Linux Intel Driver .DEB i686 (newer, but not marked as "recommended")




After installing the drivers, the printer shows up under Network Printer twice:


Xerox WorkCentre 7855 v1CMD:PDF,PS,PCL,TIFF,JPEG,PWG,URF (xerox,


Description: IPP network printer via DNS-SD

Connection: IPP network printer via DNS-SD (the only choice)




Xerox WorkCentre 7855  (



Port number: 9100


Connection: AppSocket/HP JetDirect


2) Which of those two should I choose?


I created both, and can talk to the printer with both (currently, the 'no accounting code' error prints out when I send a job). I was able to print using the latter, during a test where I added the computer's IP address to an exception list.




3) Which driver should I choose?


Here is what I did:


√ Select printer from database: Xerox (recommended) (not: Provide PPD file; not: Search for a printer driver to download * (see what happens with the other choices:)



"The foomatic printer database contains various manufacturer provided PostScript Printer Description (PPD) files and also can generate PPD files for a large number of (non Postscript) printers. But in general manufacturers provided PP files provide better access to the specific features of the printer."


When Search for a printer was chosen, the Make and model: Xerox WorkCentre 7855 appeared. Clicked: Search. Got: Printer model: - No matches found 


Tried Provide PPD file, but no such file could be found on the Xerox 7855 drivers page for Linux.


There is no WorkCentre Pro 7855. I chose WorkCentre 7345 (recommended)


Drivers: Xerox WorkCentre 7345 Foomatic/pxlcolor [en] (recommended)


Files with ".ppd" on the computer:


$ sudo find / . -print | grep -i "\.ppd"





































































find: ‘/run/user/1001/gvfs’: Permission denied


I looked at:




... and did not find this line:




(Nor was "MyUserID" in the file.)


4) What PPD file did you use?





Our 7855 uses Xerox Standard Accounting. There are no Group nor General accounts. I believe I should be using XSA User Based Accounting, and that all I need to do is Replace MyUserID the User’s User ID (once I can get the PPD figured out).


1. XSA User Based Accounting

2. XSA General Based Accounting

3. XSA Group Based Accounting

4. XNA Group Based Accounting


5) If I replace MyUSER ID with the User's ID, can I leave the other 3 sections as they stand, or should I delete them? 





0 Kudos

Re: Workcentre 7855 Accounting + Linux = Problems

Jump to solution



Having the same issue with Ubuntu 16 and Xerox 7556, Do you have an example on how the line with accounting code looks?


Have found a few other examples via google and even the doc in this post but none ot them worked



0 Kudos

Re: Workcentre 7855 Accounting + Linux = Problems

Jump to solution

Nevermind. I found out that one needs to put the XSA code between these two lines:

*JCLEnd:"<1B>%-12345X@PJL EOJ<0A><1B>%-12345X<0A>"

 I'm writing something up just in case someone else has this issue.

Re: Workcentre 7855 Accounting + Linux = Problems

Jump to solution

Thanks for responding, Joe!


There's not too much difference between Linux Mint and Ubuntu from what I understand and have experienced. The menu in the XFCE version is exactly the same in Xubuntu with system-printer-config.


Admittedly, kind of a newbie with this. Is there any location within the ppd that I should copy and paste the General Accounting code?


Since we track everyone per user ID and use the standard 999999 for the group, I'm spitballing and thinking the above might be the only problem I have.


If you could provide an example of how you modified your ppd,  that would be a great help!



0 Kudos
Joe Arseneau
Valued Advisor
Valued Advisor

Re: Workcentre 7855 Accounting + Linux = Problems

Jump to solution

I followed that document with XSA on the 7855 today on Ubuntu 16.04 and it worked, if there is an issue with Mint, you may need to call Xerox 2nd level.



Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos

Workcentre 7855 Accounting + Linux = Problems

Jump to solution
Product Name: Other - specify product in post


So, let me preface this by saying I've read how Xerox software is not compatible with CUPS now, which lead me down the path to extra the ppd file from Windows. I used this as a guide to modify the ppd for accounting purposes:


We have XSA enabled at the school where I work, and I have complete access to the printer in terms of admin passwords. My issues is that when I follow the above instructions, I continually receive accounting errors indicatng invalid accounting codes.


Is there an update version of the above link somewhere that I am missing? I noticed the updated Workcentre software published in February, but that did not install correctly on Linux Mint (which is Ubuntu and Debian-based).


Any information would be very appreciated!

0 Kudos