cancel
Showing results for 
Search instead for 
Did you mean: 
Technical Escalation User Steve991237-xrx
Technical Escalation User

App Gallery error when adding app from Web interface.

I have a Partner trying to add applpications via the App Gallery web interface and getting non specific error. see attached.

Any ideas?

 

 

0 Kudos
3 Replies
Xerox Employee XAS-Moderator
Xerox Employee

Re: App Gallery error when adding app from Web interface.

Hello, Steve.

 

Thanks for the message.

 

There are a couple items that could cause a 'no fault reason' message.

Can you tell me what model device the Partner is attempting to install apps on?

What firmware version is installed on the device?

 

This message could display:

- If the browser plug-in/extension is not installed. 

 

- if the Proxy is not set properly.

Check that the proxy is either enabled/disabled in two locations.

Using the device CWIS pages (open a browser and enter the device IP address), select the following:

Properties > General Setup > Extensible Service Setup > scroll down to the proxy server section and select Proxy from the dropdown if your network requires a proxy or select No Proxy if your network does not require a proxy.

 

Properties > Connectivity > Setup > Select Edit next to Proxy Server and check the Enabled checkbox and fill in the Proxy server address if your network requires a proxy or uncheck the Enabled checkbox to disable the proxy if your network does not require a proxy

 

- if the DNS is not set properly.

Check the DNS settings are correct.

Using the device CWIS pages (open a browser and enter the device IP address), select the following:

Properties > Connectivity > Setup > Select Edit next to Wired Connection > Select Edit next to IP (Internet Protocol) > Select Show DNS Settings and verify there is a Verified Host Name and DNS server addresses.

 

If neither of these settings are the issue, please let me know and I'll investigate further.

Thank you,

XAS Moderator

0 Kudos
Jacque New Member
New Member

Re: App Gallery error when adding app from Web interface.

I am getting the same error when trying to install on a C405. I can't follow your suggestion to the original answer, since when I go into CWIS I don't have the choices of Properties, General Setup, Extensible Service Setup.

Please advise.

JC

0 Kudos
Xerox Employee XAS-Moderator
Xerox Employee

Re: App Gallery error when adding app from Web interface.

Hello, JC. 

Thank you for the message. 

Yes, the VersaLink devices have a slightly different CWIS.  I've included updated information to correspond to the VersaLink CWIS. 

There's one other setting that you should check.  Can you verify that the device Administrator Username and Password are set correctly in App Gallery.  To do check this, launch the App Gallery. Log in and select the Devices tab.  Locate the device that you're not able to install on and select the Edit button.  Reenter the Device Username and Password if they are not correct, then retry the app install. 

If the error still occurs, please continue to check the other settings mentioned below. 

To check the device proxy is enabled and set properly follow these steps: 

Check that the proxy is either enabled/disabled in two locations.  If you site does not use any proxy, then this should be disabled. 

Using the device CWIS pages (open a browser and enter the device IP address), select the following. 

Connectivity > HTTP  - Make sure that the Proxy Server is enable.  If the switch if off (all gray), slide it to the right.  The switch icon will change to a blue button with a white checkmark when the option is enabled.  To set the Proxy, click on the Type and select either IPv4, IPv6 or Host Name.  Fill in the Proxy server information, including Port number and select OK to save your information. 

Apps > EIP Settings - On the Extensible Interface Platform page, verify that the ‘Use Device Proxy Server’ option is enabled.  If the button is all gray, slide it to the right to enable the setting.  The system should automatically pick up the proxy settings that you entered on the Connectivity screen.  If the proxy information does not populate, click the Proxy Server link and re-enter the proxy information.

 

To check that the DNS settings are correct.

Using the device CWIS pages (open a browser and enter the device IP address), select the following:

Connectivity > Ethernet  - Verify the DNS settings.  If they do not seem to be correct, scroll down to the DNS section.  Select the Edit button to modify/update the DNS settings.  Contact your System Administrator for DNS setting assistance.

Please let me know if the app install is still not successful and we'll continue to investigate. 

Thank you, 

XAS Moderator

0 Kudos