Showing results for 
Search instead for 
Did you mean: 
1 Reply
Joe Arseneau
Valued Advisor
Valued Advisor

Re: Xerox Phaser 3052 no airprint/no wifi on Airport

Set the routers 2.4GHz radio to 802.11b/g/n and the printer will see it. If it doesn't, then the WiFi chip is bad, but since it sees every router except yours, we can safely assume that is not the case, and that the router is the problem, not the printer.


It isn't capable of a 5GHz connection, you need the WPSA for that. And it won't connect via WiFi if the network cable is plugged in.


There is absolutely no point in trying to get a mobile device to connect via an app, if it isn't on the LAN, the app certainly won't be able to connect to it. It supports WiFi direct, so an Android device could connect even if it wasn't on the LAN, but you need to configure that option form its web page, which you can't get to since it isn't on the LAN.


If it doesn't work wired and it was set to do so properly then that would have to imply , when combined with your WiFi issues, that not only are you implying that the WiFi chip is bad, but the NIC as well. If the machine is that broken, I would be shocked to see it not just able to boot up in the first place, but it certainly would not do so with no relevant fault(s)


Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
New Member
New Member

Xerox Phaser 3052 no airprint/no wifi on Airport



I recently bought Xerox Phaser 3052. My network is WiFi 5 and 2,4 ghz (Air Port Extreme).

I tried setting Wi Fi connection on my macbook ( no win) but nothing works.

I tried most of sollutions from web but result is the same. Printer can't see my network. I tried settin up a mobile hotspot and it printer finds it but still can't connect. This has been a true nightmare. This message is my last try to fix this.

Things I tried:

- connecting via app Xerox Print portal on iphone. Entered ip address of printer but it doesnt connect

- downloading, installing drivers and xerox easy manager. I tried all 3 options of setting up wireless connection and none of them works. When setting up wireless connection when printer is plugged via USB it sees all wifi but not mine. Other devices with 802.11 b/g/n are able to connect.

- plugging in ethernet cable to Air port but also couldnt connect


Looking forwared to any solution that can help me print over wifi as printing via usb is not the reason I bought Xerox Phaser 3052

0 Kudos